Bug 180697 - Make ServiceWorkers follow the DEFAULT_EXPERIMENTAL_FEATURES_ENABLED flag on Mac
Summary: Make ServiceWorkers follow the DEFAULT_EXPERIMENTAL_FEATURES_ENABLED flag on Mac
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Service Workers (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: youenn fablet
URL:
Keywords: InRadar
: 180700 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-12-12 09:03 PST by youenn fablet
Modified: 2017-12-12 15:11 PST (History)
6 users (show)

See Also:


Attachments
Patch (1.20 KB, patch)
2017-12-12 09:04 PST, youenn fablet
no flags Details | Formatted Diff | Diff
Patch (1.66 KB, patch)
2017-12-12 09:48 PST, Brady Eidson
no flags Details | Formatted Diff | Diff
Patch (1.84 KB, patch)
2017-12-12 10:23 PST, Brady Eidson
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description youenn fablet 2017-12-12 09:03:46 PST
As a first step towards activating service worker everywhere, make Service Worker experimental flag on by default.
Comment 1 youenn fablet 2017-12-12 09:04:26 PST
Created attachment 329115 [details]
Patch
Comment 2 Chris Dumez 2017-12-12 09:11:26 PST
Comment on attachment 329115 [details]
Patch

I am unclear if this enables the feature on iOS or not. I think we'd want to hold off on iOS a bit until we do some basic testing.
Comment 3 Brady Eidson 2017-12-12 09:28:45 PST
(In reply to Chris Dumez from comment #2)
> Comment on attachment 329115 [details]
> Patch
> 
> I am unclear if this enables the feature on iOS or not. I think we'd want to
> hold off on iOS a bit until we do some basic testing.

Right. That's the reason why I hadn't done this yet (e.g resolve the radar) because I'm waiting on input on how to use the yaml to be Mac only.
Comment 4 Brady Eidson 2017-12-12 09:29:05 PST
Comment on attachment 329115 [details]
Patch

Gotta do this differently
Comment 5 Brady Eidson 2017-12-12 09:29:43 PST
*** Bug 180700 has been marked as a duplicate of this bug. ***
Comment 6 Brady Eidson 2017-12-12 09:48:47 PST
Created attachment 329118 [details]
Patch
Comment 7 Chris Dumez 2017-12-12 09:50:24 PST
Comment on attachment 329118 [details]
Patch

r=me assuming iOS EWS is happy.
Comment 8 Brady Eidson 2017-12-12 10:16:57 PST
It's no good, but I have a good fix.
Comment 9 Brady Eidson 2017-12-12 10:23:37 PST
Created attachment 329123 [details]
Patch
Comment 10 WebKit Commit Bot 2017-12-12 10:48:17 PST
Comment on attachment 329123 [details]
Patch

Clearing flags on attachment: 329123

Committed r225789: <https://trac.webkit.org/changeset/225789>
Comment 11 WebKit Commit Bot 2017-12-12 10:48:19 PST
All reviewed patches have been landed.  Closing bug.
Comment 12 Brady Eidson 2017-12-12 10:53:21 PST
<rdar://problem/35978311>
Comment 13 Matt Lewis 2017-12-12 14:04:43 PST
This caused multiple API failures on all macOS platforms:



https://build.webkit.org/builders/Apple%20El%20Capitan%20Release%20WK1%20%28Tests%29/builds/6953/steps/run-api-tests/logs/stdio
Build:
https://build.webkit.org/builders/Apple%20El%20Capitan%20Release%20WK1%20%28Tests%29/builds/6953/steps/run-api-tests/logs/stdio

The failing tests:

WKProcessPool.InitialWarmedProcessUsed

Failure:
FAIL WKProcessPool.InitialWarmedProcessUsed

/Volumes/Data/slave/elcapitan-release/build/Tools/TestWebKitAPI/Tests/WebKitCocoa/InitialWarmedProcessUsed.mm:51
Value of: static_cast<size_t>(1)
  Actual: 1
Expected: [pool _webProcessCount]
Which is: 2


WebKit.WebsiteDataStoreCustomPaths

FAIL WebKit.WebsiteDataStoreCustomPaths

/Volumes/Data/slave/elcapitan-release/build/Tools/TestWebKitAPI/Tests/WebKitCocoa/WebsiteDataStoreCustomPaths.mm:219
Value of: [WKWebsiteDataStore _defaultDataStoreExists]
  Actual: true
Expected: false


The test passed before this patch and now fail consistently
Comment 14 Matt Lewis 2017-12-12 15:11:40 PST
New bug for the failures and the fix:
https://bugs.webkit.org/show_bug.cgi?id=180722