Bug 180685 - REGRESSION(r225683): Chakra test failure in es6/regex-unicode.js for 32bit builds
Summary: REGRESSION(r225683): Chakra test failure in es6/regex-unicode.js for 32bit bu...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Michael Saboff
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2017-12-11 16:59 PST by Michael Saboff
Modified: 2017-12-11 21:47 PST (History)
7 users (show)

See Also:


Attachments
Patch (1.86 KB, patch)
2017-12-11 17:09 PST, Michael Saboff
sbarati: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Saboff 2017-12-11 16:59:14 PST
https://build.webkit.org/builders/Apple%20High%20Sierra%2032-bit%20JSC%20%28BuildAndTest%29/builds/671
https://build.webkit.org/builders/Apple%20High%20Sierra%2032-bit%20JSC%20%28BuildAndTest%29/builds/671/steps/webkit-32bit-jsc-test/logs/stdio

failure:
ChakraCore.yaml/ChakraCore/test/es6/regex-unicode.js.default

ChakraCore.yaml/ChakraCore/test/es6/regex-unicode.js.default: Detected failures:
ChakraCore.yaml/ChakraCore/test/es6/regex-unicode.js.default: *** Running test #4 (3): A character set containing a range spanning multiple planes should match characters from all those planes
ChakraCore.yaml/ChakraCore/test/es6/regex-unicode.js.default: Test threw exception: assert.isTrue failed: expected: true actual: false: First character in plane #1
ChakraCore.yaml/ChakraCore/test/es6/regex-unicode.js.default: FAILED
ChakraCore.yaml/ChakraCore/test/es6/regex-unicode.js.default: Summary of tests: total executed: 7; passed: 6; failed: 1
FAIL: ChakraCore.yaml/ChakraCore/test/es6/regex-unicode.js.default
Comment 1 Radar WebKit Bug Importer 2017-12-11 17:00:09 PST
<rdar://problem/35982788>
Comment 2 Michael Saboff 2017-12-11 17:09:25 PST
Created attachment 329060 [details]
Patch
Comment 3 Alex Christensen 2017-12-11 17:21:51 PST
Comment on attachment 329060 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=329060&action=review

> Source/JavaScriptCore/ChangeLog:3
> +        REGREASSION(r225683): Chakra test failure in es6/regex-unicode.js for 32bit builds

I don't understand why this would be specific to 32-bit builds.
Comment 4 Michael Saboff 2017-12-11 21:42:04 PST
(In reply to Alex Christensen from comment #3)
> Comment on attachment 329060 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=329060&action=review
> 
> > Source/JavaScriptCore/ChangeLog:3
> > +        REGREASSION(r225683): Chakra test failure in es6/regex-unicode.js for 32bit builds
> 
> I don't understand why this would be specific to 32-bit builds.

Because Unicode regular expressions are handled by JIT'ed code on 64 bit platforms.  The failure was in the interpreter.
Comment 5 Michael Saboff 2017-12-11 21:47:20 PST
Committed r225771: <https://trac.webkit.org/changeset/225771>