Bug 180597 - Web Inspector: recording view and slider have jumbled layout at narrow widths
Summary: Web Inspector: recording view and slider have jumbled layout at narrow widths
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: WebKit Nightly Build
Hardware: All All
: P2 Normal
Assignee: Devin Rousso
URL:
Keywords: InRadar
Depends on:
Blocks: WebInspectorCanvasRecording
  Show dependency treegraph
 
Reported: 2017-12-08 12:17 PST by Brian Burg
Modified: 2017-12-18 13:51 PST (History)
7 users (show)

See Also:


Attachments
screenshot (1.15 MB, image/png)
2017-12-08 12:17 PST, Brian Burg
no flags Details
Patch (2.05 KB, patch)
2017-12-14 21:30 PST, Devin Rousso
no flags Details | Formatted Diff | Diff
[Image] After Patch is applied (164.14 KB, image/png)
2017-12-14 21:30 PST, Devin Rousso
no flags Details
Archive of layout-test-results from ews115 for mac-elcapitan (3.34 MB, application/zip)
2017-12-15 00:59 PST, EWS Watchlist
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Burg 2017-12-08 12:17:52 PST
Created attachment 328849 [details]
screenshot

via Nelson Thachuk. See screenshot.
Comment 1 Brian Burg 2017-12-08 12:18:50 PST
<rdar://problem/35939904>
Comment 2 Devin Rousso 2017-12-14 21:30:19 PST
Created attachment 329456 [details]
Patch
Comment 3 Devin Rousso 2017-12-14 21:30:31 PST
Created attachment 329457 [details]
[Image] After Patch is applied
Comment 4 EWS Watchlist 2017-12-15 00:59:08 PST Comment hidden (obsolete)
Comment 5 EWS Watchlist 2017-12-15 00:59:10 PST Comment hidden (obsolete)
Comment 6 Devin Rousso 2017-12-18 13:31:32 PST
Comment on attachment 329456 [details]
Patch

The test failure is unrelated (caused by <https://webkit.org/b/180770>).
Comment 7 WebKit Commit Bot 2017-12-18 13:51:40 PST
Comment on attachment 329456 [details]
Patch

Clearing flags on attachment: 329456

Committed r226077: <https://trac.webkit.org/changeset/226077>
Comment 8 WebKit Commit Bot 2017-12-18 13:51:41 PST
All reviewed patches have been landed.  Closing bug.