Bug 180441 - WebAssembly: don't eagerly checksum
Summary: WebAssembly: don't eagerly checksum
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: JF Bastien
URL:
Keywords: InRadar
Depends on: 179343
Blocks:
  Show dependency treegraph
 
Reported: 2017-12-05 13:32 PST by JF Bastien
Modified: 2017-12-05 14:50 PST (History)
10 users (show)

See Also:


Attachments
patch (10.51 KB, patch)
2017-12-05 13:37 PST, JF Bastien
saam: review+
Details | Formatted Diff | Diff
patch (10.50 KB, patch)
2017-12-05 14:17 PST, JF Bastien
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description JF Bastien 2017-12-05 13:32:06 PST
It looks like it may have caused a regression, but I can't repro it. For now just don't checksum, and we can revisit later when I have time. Let's see what perf bots say.
Comment 1 JF Bastien 2017-12-05 13:32:27 PST
<rdar://problem/35156628>
Comment 2 JF Bastien 2017-12-05 13:37:58 PST
Created attachment 328494 [details]
patch
Comment 3 EWS Watchlist 2017-12-05 13:40:10 PST
Attachment 328494 [details] did not pass style-queue:


ERROR: Source/JavaScriptCore/wasm/WasmNameSection.h:41:  Weird number of spaces at line-start.  Are you using a 4-space indent?  [whitespace/indent] [3]
ERROR: Source/JavaScriptCore/wasm/WasmNameSection.h:42:  Weird number of spaces at line-start.  Are you using a 4-space indent?  [whitespace/indent] [3]
ERROR: Source/JavaScriptCore/wasm/WasmNameSection.h:48:  When wrapping a line, only indent 4 spaces.  [whitespace/indent] [3]
Total errors found: 3 in 9 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 4 Saam Barati 2017-12-05 13:42:00 PST
Comment on attachment 328494 [details]
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=328494&action=review

r=me

> Source/JavaScriptCore/runtime/Options.h:481
> +    v(bool, eagerlyHashWebAssemblyModules, false, Normal, "Unnamed WebAssembly modules are identified in backtraces through their hash, if available.") \

nit: I'd name this starting with "use" to be consistent with many of our other options. Maybe:
useEagerWebAssemblyModuleHashing?
Comment 5 JF Bastien 2017-12-05 14:17:40 PST
Created attachment 328498 [details]
patch

Address comments.
Comment 6 WebKit Commit Bot 2017-12-05 14:50:35 PST
Comment on attachment 328498 [details]
patch

Clearing flags on attachment: 328498

Committed r225550: <https://trac.webkit.org/changeset/225550>
Comment 7 WebKit Commit Bot 2017-12-05 14:50:37 PST
All reviewed patches have been landed.  Closing bug.