Bug 180437 - REGRESSION: API Test WTF.StringOperators is failing on release testers
Summary: REGRESSION: API Test WTF.StringOperators is failing on release testers
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2017-12-05 12:28 PST by Matt Lewis
Modified: 2017-12-06 16:47 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Lewis 2017-12-05 12:28:31 PST
The API test WTF.StringOperators is failing on release testers on all platforms currently. I have been unable to reproduce the failure locally. I have managed to narrow the failure down to between the revisions r225430 - r225435. I was able to reproduce the failure on one of the testers, but was unable to fully narrow down the regression point.
Comment 2 Matt Lewis 2017-12-05 12:29:30 PST
Failure:

FAIL WTF.StringOperators

/Volumes/Data/slave/sierra-release/build/Tools/TestWebKitAPI/Tests/WTF/StringOperators.cpp:52
Value of: wtfStringCopyCount
  Actual: 0
Expected: 2
string + string


/Volumes/Data/slave/sierra-release/build/Tools/TestWebKitAPI/Tests/WTF/StringOperators.cpp:54
Value of: wtfStringCopyCount
  Actual: 0
Expected: 2
atomicString + string
Comment 3 Ryan Haddad 2017-12-05 15:54:16 PST
I could not reproduce the failure with a build of r225429, but I can reproduce after doing a clean build of r225430.
Comment 4 Matt Lewis 2017-12-05 15:56:33 PST
I was also able to reproduce the failure on one of the testers consistently.
Comment 5 Matt Lewis 2017-12-05 16:01:33 PST
The revision was rolled out in https://trac.webkit.org/changeset/225555

Closing bug
Comment 6 Radar WebKit Bug Importer 2017-12-06 16:47:22 PST
<rdar://problem/35896595>