Bug 180361 - AX: Implement updated CSS3 Speech for 'speak' and 'speak-as' properties
Summary: AX: Implement updated CSS3 Speech for 'speak' and 'speak-as' properties
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Accessibility (show other bugs)
Version: WebKit Nightly Build
Hardware: All All
: P2 Normal
Assignee: chris fleizach
URL:
Keywords: InRadar
: 167692 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-12-04 09:36 PST by chris fleizach
Modified: 2018-01-05 10:00 PST (History)
9 users (show)

See Also:


Attachments
patch (40.00 KB, patch)
2017-12-18 17:02 PST, chris fleizach
no flags Details | Formatted Diff | Diff
patch (40.50 KB, patch)
2017-12-18 17:25 PST, chris fleizach
ews: commit-queue-
Details | Formatted Diff | Diff
Archive of layout-test-results from ews102 for mac-elcapitan (2.64 MB, application/zip)
2017-12-18 18:30 PST, Build Bot
no flags Details
Archive of layout-test-results from ews113 for mac-elcapitan (2.96 MB, application/zip)
2017-12-18 19:01 PST, Build Bot
no flags Details
Archive of layout-test-results from ews105 for mac-elcapitan-wk2 (2.83 MB, application/zip)
2017-12-18 19:24 PST, Build Bot
no flags Details
patch (45.21 KB, patch)
2017-12-18 23:51 PST, chris fleizach
ews: commit-queue-
Details | Formatted Diff | Diff
Archive of layout-test-results from ews103 for mac-elcapitan (2.21 MB, application/zip)
2017-12-19 00:55 PST, Build Bot
no flags Details
Archive of layout-test-results from ews105 for mac-elcapitan-wk2 (2.54 MB, application/zip)
2017-12-19 01:06 PST, Build Bot
no flags Details
Archive of layout-test-results from ews126 for ios-simulator-wk2 (2.16 MB, application/zip)
2017-12-19 01:22 PST, Build Bot
no flags Details
Archive of layout-test-results from ews116 for mac-elcapitan (2.91 MB, application/zip)
2017-12-19 01:24 PST, Build Bot
no flags Details
patch (48.76 KB, patch)
2017-12-20 10:05 PST, chris fleizach
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description chris fleizach 2017-12-04 09:36:24 PST
* SUMMARY
Implement updated CSS3 Speech for 'speak' and 'speak-as' properties

* NOTES
http://dev.w3.org/csswg/css3-speech/#speaking-props-speak
http://dev.w3.org/csswg/css3-speech/#speaking-props-speak-as

The CSS group rejected our request to go back to the original values for 'speak' even though their draft had stagnated for 6 years. Nevertheless, some good will come out of this. For example, the property values are not mutually exclusive as I originally thought. Note the double vertical bars.

speak-as: normal | spell-out || digits || [ literal-punctuation | no-punctuation ]

e.g. these examples will work.

.telephone {
   speak-as: digits no-punctuation; /* e.g., (415) 555-1212 */
}

<rdar://problem/10353542>
Comment 1 chris fleizach 2017-12-18 17:02:10 PST
Created attachment 329714 [details]
patch
Comment 2 Build Bot 2017-12-18 17:04:46 PST
Attachment 329714 [details] did not pass style-queue:


ERROR: Source/WebCore/css/parser/CSSPropertyParser.cpp:3595:  A case label should not be indented, but line up with its switch statement.  [whitespace/indent] [4]
Total errors found: 1 in 29 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 chris fleizach 2017-12-18 17:25:49 PST
Created attachment 329717 [details]
patch
Comment 4 Build Bot 2017-12-18 18:30:31 PST
Comment on attachment 329717 [details]
patch

Attachment 329717 [details] did not pass mac-ews (mac):
Output: http://webkit-queues.webkit.org/results/5736836

New failing tests:
svg/css/getComputedStyle-basic.xhtml
fast/css/getComputedStyle/computed-style.html
fast/css/getComputedStyle/computed-style-without-renderer.html
Comment 5 Build Bot 2017-12-18 18:30:32 PST
Created attachment 329722 [details]
Archive of layout-test-results from ews102 for mac-elcapitan

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: ews102  Port: mac-elcapitan  Platform: Mac OS X 10.11.6
Comment 6 Build Bot 2017-12-18 19:01:19 PST
Comment on attachment 329717 [details]
patch

Attachment 329717 [details] did not pass mac-debug-ews (mac):
Output: http://webkit-queues.webkit.org/results/5737005

New failing tests:
svg/css/getComputedStyle-basic.xhtml
fast/css/getComputedStyle/computed-style.html
fast/css/getComputedStyle/computed-style-without-renderer.html
Comment 7 Build Bot 2017-12-18 19:01:21 PST
Created attachment 329725 [details]
Archive of layout-test-results from ews113 for mac-elcapitan

The attached test failures were seen while running run-webkit-tests on the mac-debug-ews.
Bot: ews113  Port: mac-elcapitan  Platform: Mac OS X 10.11.6
Comment 8 Build Bot 2017-12-18 19:24:40 PST
Comment on attachment 329717 [details]
patch

Attachment 329717 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.webkit.org/results/5737803

New failing tests:
fast/css/getComputedStyle/computed-style-without-renderer.html
fast/css/getComputedStyle/computed-style.html
svg/css/getComputedStyle-basic.xhtml
Comment 9 Build Bot 2017-12-18 19:24:41 PST
Created attachment 329727 [details]
Archive of layout-test-results from ews105 for mac-elcapitan-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: ews105  Port: mac-elcapitan-wk2  Platform: Mac OS X 10.11.6
Comment 10 chris fleizach 2017-12-18 23:51:34 PST
Created attachment 329741 [details]
patch
Comment 11 Build Bot 2017-12-19 00:55:47 PST
Comment on attachment 329741 [details]
patch

Attachment 329741 [details] did not pass mac-ews (mac):
Output: http://webkit-queues.webkit.org/results/5744885

New failing tests:
fast/css/getComputedStyle/computed-style-without-renderer.html
fast/css/getComputedStyle/computed-style.html
Comment 12 Build Bot 2017-12-19 00:55:48 PST
Created attachment 329745 [details]
Archive of layout-test-results from ews103 for mac-elcapitan

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: ews103  Port: mac-elcapitan  Platform: Mac OS X 10.11.6
Comment 13 Build Bot 2017-12-19 01:06:52 PST
Comment on attachment 329741 [details]
patch

Attachment 329741 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.webkit.org/results/5744944

New failing tests:
fast/css/getComputedStyle/computed-style-without-renderer.html
fast/css/getComputedStyle/computed-style.html
Comment 14 Build Bot 2017-12-19 01:06:53 PST
Created attachment 329746 [details]
Archive of layout-test-results from ews105 for mac-elcapitan-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: ews105  Port: mac-elcapitan-wk2  Platform: Mac OS X 10.11.6
Comment 15 Build Bot 2017-12-19 01:22:24 PST
Comment on attachment 329741 [details]
patch

Attachment 329741 [details] did not pass ios-sim-ews (ios-simulator-wk2):
Output: http://webkit-queues.webkit.org/results/5745087

New failing tests:
fast/css/getComputedStyle/computed-style-without-renderer.html
fast/css/getComputedStyle/computed-style.html
Comment 16 Build Bot 2017-12-19 01:22:25 PST
Created attachment 329747 [details]
Archive of layout-test-results from ews126 for ios-simulator-wk2

The attached test failures were seen while running run-webkit-tests on the ios-sim-ews.
Bot: ews126  Port: ios-simulator-wk2  Platform: Mac OS X 10.12.6
Comment 17 Build Bot 2017-12-19 01:24:36 PST
Comment on attachment 329741 [details]
patch

Attachment 329741 [details] did not pass mac-debug-ews (mac):
Output: http://webkit-queues.webkit.org/results/5745064

New failing tests:
fast/css/getComputedStyle/computed-style-without-renderer.html
fast/css/getComputedStyle/computed-style.html
Comment 18 Build Bot 2017-12-19 01:24:37 PST
Created attachment 329748 [details]
Archive of layout-test-results from ews116 for mac-elcapitan

The attached test failures were seen while running run-webkit-tests on the mac-debug-ews.
Bot: ews116  Port: mac-elcapitan  Platform: Mac OS X 10.11.6
Comment 19 chris fleizach 2017-12-20 10:05:28 PST
Created attachment 329929 [details]
patch
Comment 20 Simon Fraser (smfr) 2018-01-03 22:15:15 PST
I filed this as bug 167692.
Comment 21 Simon Fraser (smfr) 2018-01-03 22:15:58 PST
*** Bug 167692 has been marked as a duplicate of this bug. ***
Comment 22 WebKit Commit Bot 2018-01-04 16:32:57 PST
Comment on attachment 329929 [details]
patch

Clearing flags on attachment: 329929

Committed r226432: <https://trac.webkit.org/changeset/226432>
Comment 23 WebKit Commit Bot 2018-01-04 16:32:59 PST
All reviewed patches have been landed.  Closing bug.
Comment 24 Claudio Saavedra 2018-01-05 02:12:28 PST
Hey, as you can see from the EWS bubbles you broke wincairo and wpe. I fixed wpe in https://trac.webkit.org/changeset/226441.
Comment 25 chris fleizach 2018-01-05 07:24:55 PST
(In reply to Claudio Saavedra from comment #24)
> Hey, as you can see from the EWS bubbles you broke wincairo and wpe. I fixed
> wpe in https://trac.webkit.org/changeset/226441.

Thank you!
Comment 26 Ryan Haddad 2018-01-05 09:25:22 PST
This change broke the iOS Debug build:
https://build.webkit.org/builders/Apple%20iOS%2011%20Simulator%20Debug%20%28Build%29/builds/2763

duplicate symbol __ZN22AccessibilityUIElement7speakAsEv in:
    /Volumes/Data/slave/ios-simulator-11-debug/build/WebKitBuild/Debug-iphonesimulator/libDumpRenderTree.a(AccessibilityUIElement.o)
    /Volumes/Data/slave/ios-simulator-11-debug/build/WebKitBuild/Debug-iphonesimulator/libDumpRenderTree.a(AccessibilityUIElementIOS.o)
Comment 27 chris fleizach 2018-01-05 09:26:24 PST
(In reply to Ryan Haddad from comment #26)
> This change broke the iOS Debug build:
> https://build.webkit.org/builders/
> Apple%20iOS%2011%20Simulator%20Debug%20%28Build%29/builds/2763
> 
> duplicate symbol __ZN22AccessibilityUIElement7speakAsEv in:
>    
> /Volumes/Data/slave/ios-simulator-11-debug/build/WebKitBuild/Debug-
> iphonesimulator/libDumpRenderTree.a(AccessibilityUIElement.o)
>    
> /Volumes/Data/slave/ios-simulator-11-debug/build/WebKitBuild/Debug-
> iphonesimulator/libDumpRenderTree.a(AccessibilityUIElementIOS.o)

looking now
Comment 28 chris fleizach 2018-01-05 09:28:20 PST
(In reply to chris fleizach from comment #27)
> (In reply to Ryan Haddad from comment #26)
> > This change broke the iOS Debug build:
> > https://build.webkit.org/builders/
> > Apple%20iOS%2011%20Simulator%20Debug%20%28Build%29/builds/2763
> > 
> > duplicate symbol __ZN22AccessibilityUIElement7speakAsEv in:
> >    
> > /Volumes/Data/slave/ios-simulator-11-debug/build/WebKitBuild/Debug-
> > iphonesimulator/libDumpRenderTree.a(AccessibilityUIElement.o)
> >    
> > /Volumes/Data/slave/ios-simulator-11-debug/build/WebKitBuild/Debug-
> > iphonesimulator/libDumpRenderTree.a(AccessibilityUIElementIOS.o)
> 
> looking now

Index: Tools/DumpRenderTree/AccessibilityUIElement.cpp
===================================================================
--- Tools/DumpRenderTree/AccessibilityUIElement.cpp	(revision 226449)
+++ Tools/DumpRenderTree/AccessibilityUIElement.cpp	(working copy)
@@ -1538,6 +1538,7 @@
 #endif
 
 #if !PLATFORM(MAC) && !PLATFORM(IOS)
+JSStringRef AccessibilityUIElement::speakAs() { return nullptr; }
 JSStringRef AccessibilityUIElement::pathDescription() const { return 0; }
 void AccessibilityUIElement::setValue(JSStringRef) { }
 #endif
@@ -1556,7 +1557,6 @@
 #endif
 
 #if !PLATFORM(MAC)
-JSStringRef AccessibilityUIElement::speakAs() { return nullptr; }
 void AccessibilityUIElement::setBoolAttributeValue(JSStringRef, bool) { }
 #endif
Comment 29 Ryan Haddad 2018-01-05 09:37:21 PST
Are you going to land the change, or do you need me to do it?
Comment 30 chris fleizach 2018-01-05 09:40:10 PST
(In reply to Ryan Haddad from comment #29)
> Are you going to land the change, or do you need me to do it?

I'm working on the change right now. thanks
Comment 31 Jonathan Bedard 2018-01-05 09:54:55 PST
(In reply to chris fleizach from comment #30)
> (In reply to Ryan Haddad from comment #29)
> > Are you going to land the change, or do you need me to do it?
> 
> I'm working on the change right now. thanks

I've confirmed this change for iOS Simulator Debug builds locally.
Comment 32 chris fleizach 2018-01-05 09:55:53 PST
(In reply to Jonathan Bedard from comment #31)
> (In reply to chris fleizach from comment #30)
> > (In reply to Ryan Haddad from comment #29)
> > > Are you going to land the change, or do you need me to do it?
> > 
> > I'm working on the change right now. thanks
> 
> I've confirmed this change for iOS Simulator Debug builds locally.

thanks. I was waiting on my local build to finish...
Comment 33 chris fleizach 2018-01-05 10:00:18 PST
(In reply to chris fleizach from comment #32)
> (In reply to Jonathan Bedard from comment #31)
> > (In reply to chris fleizach from comment #30)
> > > (In reply to Ryan Haddad from comment #29)
> > > > Are you going to land the change, or do you need me to do it?
> > > 
> > > I'm working on the change right now. thanks
> > 
> > I've confirmed this change for iOS Simulator Debug builds locally.
> 
> thanks. I was waiting on my local build to finish...

https://trac.webkit.org/changeset/226450/webkit