Bug 18017 - Scroll position in Inspector's Console changes when switching between panels
Summary: Scroll position in Inspector's Console changes when switching between panels
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-03-22 14:30 PDT by Oliver Hunt
Modified: 2014-01-26 12:36 PST (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Hunt 2008-03-22 14:30:57 PDT
If you fill the web inspector with a sufficient content to causing scrolling, then switch to something else in the inspector the scroll position in the console will be wrong :(
Comment 1 Timothy Hatcher 2008-03-22 14:44:18 PDT
The reason this happens is when a overflow area changes from display: none back to display: block the scrollTop and scrollLeft is reset back to 0.

Is that the intended behavior? If so we will need to add code in a few places that remembers these values and restores them later. In my opinion the engine should remember them and not reset back to 0. 
Comment 2 Nickolay 2011-03-23 03:35:14 PDT
This is very similar to bug #39284.
Comment 3 Robin Qiu 2011-04-02 01:48:09 PDT
(In reply to comment #2)
> This is very similar to bug #39284.

Checked, they have different root cause.
Comment 4 Brian Burg 2014-01-26 12:36:22 PST
Not a problem in new inspector.