Bug 179998 - Safari 11 Crash in com.apple.JavaScriptCore 0x000000010b917bb9 Inspector::ScriptCallFrame::~ScriptCallFrame() + 9
Summary: Safari 11 Crash in com.apple.JavaScriptCore 0x000000010b917bb9 Inspector::S...
Status: RESOLVED DUPLICATE of bug 180373
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebRTC (show other bugs)
Version: Safari 11
Hardware: PC Unspecified
: P2 Major
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2017-11-24 01:04 PST by xpeng
Modified: 2018-12-21 14:39 PST (History)
2 users (show)

See Also:


Attachments
CrashDump (115.10 KB, text/plain)
2017-11-24 01:04 PST, xpeng
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description xpeng 2017-11-24 01:04:03 PST
Created attachment 327529 [details]
CrashDump

Safari Crashes when using webrtc:

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   com.apple.JavaScriptCore      	0x000000010b917bb9 Inspector::ScriptCallFrame::~ScriptCallFrame() + 9
1   com.apple.JavaScriptCore      	0x000000010b918068 Inspector::ScriptCallStack::~ScriptCallStack() + 40
2   com.apple.JavaScriptCore      	0x000000010b1e1d6b Inspector::AsyncStackTrace::~AsyncStackTrace() + 139
3   com.apple.JavaScriptCore      	0x000000010b1e1f78 Inspector::AsyncStackTrace::truncate(unsigned long) + 424
4   com.apple.JavaScriptCore      	0x000000010b664608 Inspector::InspectorDebuggerAgent::willDispatchAsyncCall(int, int) + 136
5   com.apple.WebCore             	0x0000000108f7ec1d WebCore::InspectorInstrumentation::willFireTimerImpl(WebCore::InstrumentingAgents&, int, WebCore::ScriptExecutionContext&) + 125
6   com.apple.WebCore             	0x00000001088b208f WebCore::DOMTimer::fired() + 927
7   com.apple.WebCore             	0x00000001087e2320 WebCore::ThreadTimers::sharedTimerFiredInternal() + 176
8   com.apple.WebCore             	0x00000001087e225f WebCore::timerFired(__CFRunLoopTimer*, void*) + 31
Comment 1 Alexey Proskuryakov 2017-11-28 11:28:02 PST
rdar://problem/35440008
Comment 2 Joseph Pecoraro 2018-12-21 14:39:12 PST
Will address this in bug 180373.

*** This bug has been marked as a duplicate of bug 180373 ***