Split JobQueue logic out of SWServerRegistration to match the Service Workers specification more closely.
We should probably reuse the registration key and maybe rename it to scope url key since both maps will have the same key
Will try to keep the patch as small as possible. We can do more refactoring in follow-ups (e.g. getting rid of the background thread).
Created attachment 325609 [details]
Created attachment 325610 [details]
Attachment 325610 [details] did not pass style-queue:
ERROR: Source/WebCore/workers/service/server/SWServerJobQueue.h:52: The parameter name "data" adds no information, so it should be removed. [readability/parameter_name] 
Total errors found: 1 in 15 files
If any of these errors are false positives, please file a bug against check-webkit-style.
Created attachment 325616 [details]
Created attachment 325621 [details]
Created attachment 325624 [details]
Created attachment 325634 [details]
Had to rebaseline because of Brady's patch that just landed.
Comment on attachment 325634 [details]
Clearing flags on attachment: 325634
Committed r224301: <https://trac.webkit.org/changeset/224301>
All reviewed patches have been landed. Closing bug.