I am planning on moving FileSystem to PAL soon. Before work is done to move it, I'm working on cleaning up and updating the code. The functions of filesystem are global to the WebCore namespace. Adding a FileSystem namespace will help avoid naming collisions with these functions.
Created attachment 325463 [details] Patch
Created attachment 325473 [details] Patch Missed a namespace in FileSystemCoca.mm
Created attachment 325479 [details] Patch
Created attachment 325493 [details] patch
Created attachment 325504 [details] Patch Fixing some cases where FileSystem:: was wrongly added to functions with the same name as FileSystem functions.
Created attachment 325513 [details] Patch Fixing an enum using two FileSystem namespaces
Created attachment 325555 [details] Patch This should fix the remaining mac build issues
Comment on attachment 325555 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=325555&action=review I’m not thrilled by this change; I don’t really know what specific name conflicts this is preventing. But I guess it’s OK. > Source/WebCore/ChangeLog:12 > + * Modules/encryptedmedia/legacy/WebKitMediaKeySession.cpp: The file list in this change log is a mess. For example, it’s not great to just leave in all sorts of erroneous "deleted" lines for functions moved inside a namespace. The point of the change log generation tool is to start the change log for you. It’s not great to just leave all the lines in there without looking them over. For a global replace like this, might even want to leave out all the function names. > Source/WebCore/Modules/indexeddb/server/IDBServer.cpp:469 > + Vector<String> entries = WebCore::FileSystem::listDirectory(directory, ASCIILiteral("*")); Do we really need the WebCore prefix here? This code is in a namespace nested inside the WebCore namespace. I’m surprised this is required.
(In reply to Darin Adler from comment #8) > Comment on attachment 325555 [details] > Patch > > View in context: > https://bugs.webkit.org/attachment.cgi?id=325555&action=review > > I’m not thrilled by this change; I don’t really know what specific name > conflicts this is preventing. But I guess it’s OK. > > > Source/WebCore/ChangeLog:12 > > + * Modules/encryptedmedia/legacy/WebKitMediaKeySession.cpp: > > The file list in this change log is a mess. For example, it’s not great to > just leave in all sorts of erroneous "deleted" lines for functions moved > inside a namespace. The point of the change log generation tool is to start > the change log for you. It’s not great to just leave all the lines in there > without looking them over. For a global replace like this, might even want > to leave out all the function names. That's good to know, I'll clean up the ChangeLogs and I can take out all the touched function names. > > Source/WebCore/Modules/indexeddb/server/IDBServer.cpp:469 > > + Vector<String> entries = WebCore::FileSystem::listDirectory(directory, ASCIILiteral("*")); > > Do we really need the WebCore prefix here? This code is in a namespace > nested inside the WebCore namespace. I’m surprised this is required. It actually looks fine without that WebCore namespace, I'll take it out.
Created attachment 325786 [details] Patch for landing
Comment on attachment 325786 [details] Patch for landing Clearing flags on attachment: 325786 Committed r224371: <https://trac.webkit.org/changeset/224371>
All reviewed patches have been landed. Closing bug.
<rdar://problem/35567651>