Bug 178932 - [Web Animations] Implement the play() and pause() methods on Animation
Summary: [Web Animations] Implement the play() and pause() methods on Animation
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Animations (show other bugs)
Version: Safari Technology Preview
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Antoine Quint
URL:
Keywords: InRadar
: 180401 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-10-27 03:19 PDT by Antoine Quint
Modified: 2017-12-14 09:39 PST (History)
7 users (show)

See Also:


Attachments
Patch (29.64 KB, patch)
2017-12-13 15:02 PST, Antoine Quint
eric.carlson: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Antoine Quint 2017-10-27 03:19:45 PDT
The Animation interface exposes a pause() method to control the animation's playback state.
Comment 1 Radar WebKit Bug Importer 2017-10-31 06:40:23 PDT
<rdar://problem/35271069>
Comment 2 Antoine Quint 2017-12-13 14:49:47 PST
*** Bug 180401 has been marked as a duplicate of this bug. ***
Comment 3 Antoine Quint 2017-12-13 15:02:05 PST
Created attachment 329264 [details]
Patch
Comment 4 EWS Watchlist 2017-12-13 15:03:59 PST
Attachment 329264 [details] did not pass style-queue:


ERROR: Source/WebCore/animation/WebAnimation.h:103:  enum members should use InterCaps with an initial capital letter or initial 'k' for C-style enums.  [readability/enum_casing] [4]
Total errors found: 1 in 12 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 5 Eric Carlson 2017-12-14 08:45:11 PST
Comment on attachment 329264 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=329264&action=review

> Source/WebCore/ChangeLog:15
> +        Note that the play() method exposes an auto-rewing flag which we always set to true, but other specs,

Nit: "auto-rewing" ->"auto-rewinding"
Comment 6 Antoine Quint 2017-12-14 09:39:48 PST
Committed r225909: <https://trac.webkit.org/changeset/225909>