Bug 17891 - FreeBSD.org crashes
Summary: FreeBSD.org crashes
Status: RESOLVED DUPLICATE of bug 17882
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-03-17 02:25 PDT by Nick Poulos
Modified: 2008-03-17 02:31 PDT (History)
0 users

See Also:


Attachments
Sort of a testcase (in that it links to offsite files) (477 bytes, text/html)
2008-03-17 02:26 PDT, Nick Poulos
no flags Details
Crash log (21.49 KB, text/plain)
2008-03-17 02:28 PDT, Nick Poulos
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Poulos 2008-03-17 02:25:55 PDT
Heh, new to bug-submitting. Anyway:

Going to freebsd.org causes a crash in r31090 on 10.4.11. Easily reproducible - just go there.

I partially reduced the code to the following:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<title>The FreeBSD Project</title>
<link rel="stylesheet" media="screen" href="http://www.freebsd.org/layout/css/fixed.css?20060509" type="text/css" title="Normal Text" />
<script type="text/javascript" src="http://www.freebsd.org/layout/js/styleswitcher.js">
</script>
</head>
<body>
</body>
</html>

Removing the <link> element or the <script> element stops the crash. Also, removing the title="Normal Text" in the <link> element stops the crash.
Comment 1 Nick Poulos 2008-03-17 02:26:46 PDT
Created attachment 19829 [details]
Sort of a testcase (in that it links to offsite files)
Comment 2 Nick Poulos 2008-03-17 02:28:27 PDT
Created attachment 19830 [details]
Crash log
Comment 3 Nick Poulos 2008-03-17 02:31:43 PDT
Oops!

*** This bug has been marked as a duplicate of 17882 ***