Bug 178820 - REGRESSION(r223729): Speedometer 2.0 React-Redux-TodoMVC throws TypeError: undefined is not an object (evaluating 'this.moveChild')
Summary: REGRESSION(r223729): Speedometer 2.0 React-Redux-TodoMVC throws TypeError: un...
Status: RESOLVED DUPLICATE of bug 178834
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-10-25 11:57 PDT by Ryan Haddad
Modified: 2017-10-25 15:19 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Haddad 2017-10-25 11:57:05 PDT
Running Speedometer (181 of 181)
ERROR: CONSOLE MESSAGE: line 1: TypeError: undefined is not an object (evaluating 'this.moveChild')
FAILED
Finished: 42.359004 s

https://build.webkit.org/builders/Apple%20El%20Capitan%20Release%20WK2%20%28Perf%29/builds/1473
Comment 2 Ryan Haddad 2017-10-25 12:10:43 PDT
It isn't clear to me from the error message what change caused this.
Comment 5 Ryosuke Niwa 2017-10-25 12:41:05 PDT
223727: ok
Comment 6 Ryan Haddad 2017-10-25 12:59:08 PDT
(In reply to Ryan Haddad from comment #3)
> https://trac.webkit.org/log/webkit/
> ?action=stop_on_copy&mode=stop_on_copy&rev=223930&stop_rev=223913&limit=100&v
> erbose=on

Sorry for the confusion, this should have been:
https://trac.webkit.org/log/webkit/?action=stop_on_copy&mode=stop_on_copy&rev=223730&stop_rev=223713&limit=100&verbose=on
Comment 7 Ryosuke Niwa 2017-10-25 14:24:30 PDT
Confirmed the regression doesn't exist at r223727.
"React-Redux-TodoMVC" is the one hitting this regression.
Comment 8 Ryosuke Niwa 2017-10-25 15:05:42 PDT
Hm.... in my local testing, I can't reproduce this at r223728. Re-bisecting.
Comment 9 Ryosuke Niwa 2017-10-25 15:12:47 PDT
Apparently, this is caused by https://trac.webkit.org/changeset/223729, which happens to enable the feature which was meant to be implemented by https://trac.webkit.org/changeset/223691
Comment 10 Ryosuke Niwa 2017-10-25 15:19:13 PDT
The culprit was rolled out in https://trac.webkit.org/changeset/223989.

*** This bug has been marked as a duplicate of bug 178834 ***