Bug 178769 - Add service worker handle fetch support for all subresource requests
Summary: Add service worker handle fetch support for all subresource requests
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: youenn fablet
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2017-10-24 18:57 PDT by youenn fablet
Modified: 2017-11-15 12:51 PST (History)
9 users (show)

See Also:


Attachments
Patch (10.10 KB, patch)
2017-10-24 19:05 PDT, youenn fablet
no flags Details | Formatted Diff | Diff
Patch (10.33 KB, patch)
2017-10-26 13:14 PDT, youenn fablet
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description youenn fablet 2017-10-24 18:57:53 PDT
Add service worker handle fetch support for all subresource requests
Comment 1 youenn fablet 2017-10-24 19:05:01 PDT
Created attachment 324776 [details]
Patch
Comment 2 Build Bot 2017-10-25 15:07:08 PDT
Attachment 324776 [details] did not pass style-queue:


ERROR: Source/WebCore/loader/cache/CachedResourceRequest.h:99:  The parameter name "serviceWorkerIdentifier" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 1 in 10 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 WebKit Commit Bot 2017-10-25 16:32:52 PDT
Comment on attachment 324776 [details]
Patch

Clearing flags on attachment: 324776

Committed r223994: <https://trac.webkit.org/changeset/223994>
Comment 4 WebKit Commit Bot 2017-10-25 16:32:54 PDT
All reviewed patches have been landed.  Closing bug.
Comment 5 Ryan Haddad 2017-10-26 09:58:12 PDT
The test for this change is failing on High Sierra, Sierra, and iOS 11 WK2:

--- /Volumes/Data/slave/highsierra-release-tests-wk2/build/layout-test-results/http/tests/workers/service/image-fetch.https-expected.txt
+++ /Volumes/Data/slave/highsierra-release-tests-wk2/build/layout-test-results/http/tests/workers/service/image-fetch.https-actual.txt
@@ -1,6 +1,6 @@
 
 Status is no status
 Status is https://127.0.0.1:8443/resources/square100.png
-PASS: Loaded image
-Image size: 100x100
+FAIL: image loading failed
+Status is https://127.0.0.1:8443/resources/square100.png
 
https://build.webkit.org/builders/Apple%20Sierra%20Release%20WK2%20(Tests)/builds/5282
Comment 6 Ryan Haddad 2017-10-26 10:26:26 PDT
Reverted r223994 for reason:

The LayoutTest for this change is failing.

Committed r224024: <https://trac.webkit.org/changeset/224024>
Comment 7 youenn fablet 2017-10-26 11:02:08 PDT
Looking at the stderr for this test, there is:
NSURLSession/NSURLConnection HTTP load failed (kCFStreamErrorDomainSSL, -9814)

I wonder whether that is the cause.
I plan to reland the patch with test as HTTP and not HTTPS
Comment 8 youenn fablet 2017-10-26 13:14:02 PDT
Created attachment 325046 [details]
Patch
Comment 9 Build Bot 2017-10-26 13:16:26 PDT
Attachment 325046 [details] did not pass style-queue:


ERROR: Source/WebCore/loader/cache/CachedResourceRequest.h:99:  The parameter name "serviceWorkerIdentifier" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 1 in 10 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 10 WebKit Commit Bot 2017-10-26 15:57:32 PDT
Comment on attachment 325046 [details]
Patch

Clearing flags on attachment: 325046

Committed r224059: <https://trac.webkit.org/changeset/224059>
Comment 11 WebKit Commit Bot 2017-10-26 15:57:34 PDT
All reviewed patches have been landed.  Closing bug.
Comment 12 Radar WebKit Bug Importer 2017-11-15 12:51:00 PST
<rdar://problem/35568276>