Bug 178706 - [WPE] Layout test media/media-source/media-source-paint-to-canvas.html is failing
Summary: [WPE] Layout test media/media-source/media-source-paint-to-canvas.html is fai...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WPE WebKit (show other bugs)
Version: Other
Hardware: PC Linux
: P2 Normal
Assignee: Ms2ger (he/him; ⌚ UTC+1/+2)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-10-23 20:50 PDT by Michael Catanzaro
Modified: 2017-11-23 07:50 PST (History)
6 users (show)

See Also:


Attachments
Patch (1.42 KB, patch)
2017-11-23 07:16 PST, Ms2ger (he/him; ⌚ UTC+1/+2)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Catanzaro 2017-10-23 20:50:47 PDT
Layout test media/media-source/media-source-paint-to-canvas.html is failing for WPE. Updating expectations accordingly.

--- /home/buildbot/wpe/wpe-linux-64-release-tests/build/layout-test-results/media/media-source/media-source-paint-to-canvas-expected.txt
+++ /home/buildbot/wpe/wpe-linux-64-release-tests/build/layout-test-results/media/media-source/media-source-paint-to-canvas-actual.txt
@@ -3,12 +3,12 @@
 EVENT(canplay)
 RUN(video.currentTime += 1.001 / 24)
 EVENT(seeked)
-EXPECTED (canvas.getContext("2d").getImageData(250, 130, 1, 1).data[0] != '0') OK
+EXPECTED (canvas.getContext("2d").getImageData(250, 130, 1, 1).data[0] != '0'), OBSERVED '0' FAIL
 RUN(video.currentTime += 1.001 / 24)
 EVENT(seeked)
-EXPECTED (canvas.getContext("2d").getImageData(250, 130, 1, 1).data[0] != '0') OK
+EXPECTED (canvas.getContext("2d").getImageData(250, 130, 1, 1).data[0] != '0'), OBSERVED '0' FAIL
 RUN(video.currentTime += 1.001 / 24)
 EVENT(seeked)
-EXPECTED (canvas.getContext("2d").getImageData(250, 130, 1, 1).data[0] != '0') OK
+EXPECTED (canvas.getContext("2d").getImageData(250, 130, 1, 1).data[0] != '0'), OBSERVED '0' FAIL
 END OF TEST
Comment 1 Ms2ger (he/him; ⌚ UTC+1/+2) 2017-11-15 04:41:31 PST
Started failing this way in r222961-r222968; timed out before that.
Comment 2 Ms2ger (he/him; ⌚ UTC+1/+2) 2017-11-15 04:41:45 PST
*** Bug 172816 has been marked as a duplicate of this bug. ***
Comment 3 Ms2ger (he/him; ⌚ UTC+1/+2) 2017-11-23 07:16:51 PST
Created attachment 327499 [details]
Patch
Comment 4 WebKit Commit Bot 2017-11-23 07:50:17 PST
Comment on attachment 327499 [details]
Patch

Clearing flags on attachment: 327499

Committed r225116: <https://trac.webkit.org/changeset/225116>
Comment 5 WebKit Commit Bot 2017-11-23 07:50:18 PST
All reviewed patches have been landed.  Closing bug.