Bug 178420 - The compiler should always register a structure when it adds its transitionWatchPointSet.
Summary: The compiler should always register a structure when it adds its transitionWa...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Mark Lam
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2017-10-17 17:17 PDT by Mark Lam
Modified: 2017-10-18 10:42 PDT (History)
7 users (show)

See Also:


Attachments
proposed patch. (18.22 KB, patch)
2017-10-17 17:33 PDT, Mark Lam
saam: review+
Details | Formatted Diff | Diff
patch for landing. (18.51 KB, patch)
2017-10-18 09:37 PDT, Mark Lam
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Lam 2017-10-17 17:17:39 PDT
<rdar://problem/34814024>
Comment 1 Mark Lam 2017-10-17 17:33:06 PDT
Created attachment 324074 [details]
proposed patch.
Comment 2 Filip Pizlo 2017-10-17 17:36:29 PDT
Comment on attachment 324074 [details]
proposed patch.

View in context: https://bugs.webkit.org/attachment.cgi?id=324074&action=review

r=me, but I suggest a name change.

> Source/JavaScriptCore/dfg/DFGGraph.h:231
> +    void registerAndWatchStructure(Structure*);

Structures have multiple watchpoint sets, and we're adding new ones all the time.  Saam's poly proto adds more.

So, I would change this name to be more descriptive.  Maybe: registerStructureAndWatchTransition.
Comment 3 Saam Barati 2017-10-17 17:42:20 PDT
(In reply to Filip Pizlo from comment #2)
> Comment on attachment 324074 [details]
> proposed patch.
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=324074&action=review
> 
> r=me, but I suggest a name change.
> 
> > Source/JavaScriptCore/dfg/DFGGraph.h:231
> > +    void registerAndWatchStructure(Structure*);
> 
> Structures have multiple watchpoint sets, and we're adding new ones all the
> time.  Saam's poly proto adds more.
> 
> So, I would change this name to be more descriptive.  Maybe:
> registerStructureAndWatchTransition.

+1 for this name
Comment 4 Mark Lam 2017-10-18 09:37:07 PDT
Created attachment 324125 [details]
patch for landing.

Thanks for the reviews.  I've applied the requested rename.  Will land shortly.
Comment 5 Mark Lam 2017-10-18 10:42:44 PDT
Landed in r223614: <http://trac.webkit.org/r223614>.