Remove unnecessary include from Document.h
Created attachment 323617 [details] Patch
Created attachment 323620 [details] Patch
Comment on attachment 323620 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=323620&action=review > Source/WebCore/dom/Document.cpp:5548 > + return m_touchEventTargets ? m_touchEventTargets->size() : false; I think we should use && instead of ? : for this. > Source/WebCore/dom/Document.cpp:5557 > + return m_touchEventTargets ? m_touchEventTargets->contains(&node) : false; Ditto.
http://trac.webkit.org/r223425
<rdar://problem/35012315>
Reverted r223425 for reason: This change broke internal builds. Committed r223443: <https://trac.webkit.org/changeset/223443>
(In reply to Ryan Haddad from comment #6) > Reverted r223425 for reason: > > This change broke internal builds. > > Committed r223443: <https://trac.webkit.org/changeset/223443> See radar for details.
This r+ patch got backed out but what it was trying to modify is still present: https://github.com/WebKit/WebKit/blob/b6c018250b04a3642c07f2bd1feb7ad3aaca312a/Source/WebCore/dom/Document.h#L1300 https://github.com/WebKit/WebKit/blob/b6c018250b04a3642c07f2bd1feb7ad3aaca312a/Source/WebCore/dom/Document.h#L66 Do we need this anymore? Appreciate if someone can mark this accordingly. Thanks!