Bug 178121 - no audio in webrtc on mac after "macOS High Sierra 10.13 Supplemental Update"
Summary: no audio in webrtc on mac after "macOS High Sierra 10.13 Supplemental Update"
Status: RESOLVED CONFIGURATION CHANGED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebRTC (show other bugs)
Version: Safari 11
Hardware: Macintosh macOS 10.13
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2017-10-10 03:01 PDT by Marcel
Modified: 2019-06-12 13:08 PDT (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcel 2017-10-10 03:01:29 PDT
After running "macOS High Sierra 10.13 Supplemental Update" on our mac's the audio isn't working any more in webrtc.
(We have confirmed this issues with 3 macbook pro's and one imac)

If we test with https://appr.tc we also have no audio in safari. 
If we use one safari and one chrome browser the audio is received on the safari end and on audio is received on the chrome end.

An other example of this issue: this example isn't working anymore: 
https://webrtc.github.io/samples/src/content/getusermedia/volume/

We still have one Mac that does have High Sierra installed but not "macOS High Sierra 10.13 Supplemental Update" and on this one the audio in webrtc is still working.

With our own webrtc webapp we run into similar issues
Comment 1 Jon Lee 2017-10-10 14:17:09 PDT
If you go to the system menu and click "About This Mac" and click on the Version label, what is the specific label string you're seeing? (Like 17A000)
Comment 2 Marcel 2017-10-11 02:18:18 PDT
On High Sierra version 10.13 (17A405) the audio fails. This one has the "macOS High Sierra 10.13 Supplemental Update"
On Sierra version 10.12.6 (16G29) the audio works. (with safari 11)

Unfortunately the machine with High Sierra but without the "macOS High Sierra 10.13 Supplemental Update" has updated automatically over night.
Comment 3 agener917 2017-10-11 18:54:55 PDT
We are experiencing the exact same bug.  But we are still on High Sierra 10.12.6 (16G29). 
The Safari version is: 11.0 (12604.1.38.1.7)
Comment 4 youenn fablet 2017-10-11 20:10:57 PDT
(In reply to agener917 from comment #3)
> We are experiencing the exact same bug.  But we are still on High Sierra
> 10.12.6 (16G29). 
> The Safari version is: 11.0 (12604.1.38.1.7)

agener917, Is it also https://webrtc.github.io/samples/src/content/getusermedia/volume/ that is not working?

Agener, Marcel:
- Would you be able to activate mock sources (Develop Menu -> WebRTC -> Use Mock Capture Devices)?

Would you also able to test with STP?
Comment 5 Marcel 2017-10-12 02:31:02 PDT
On the 17A405 I can hear the mockup audio when Use Mock Capture Devices is switched on.
Comment 6 youenn fablet 2017-10-12 08:33:00 PDT
Thanks Marcel,

Can you try https://youennf.github.io/webrtc-tests/src/content/getusermedia/volume/ ?

This is the same as https://webrtc.github.io/samples/src/content/getusermedia/volume/ but with echo cancellation off.
Comment 7 Marcel 2017-10-12 12:22:58 PDT
This does not fix the problem, unfortunately.
Comment 8 Radar WebKit Bug Importer 2017-10-13 07:54:21 PDT
<rdar://problem/34977864>
Comment 9 Marcel 2017-11-03 02:18:27 PDT
After installing the latest version 10.13.1 (17B48) of High Sierra we found out some interesting facts.

We started out with two macbook pro's one with the Safari Technology Preview installed (probably version 42) and one without the Safari Technology Preview. At this point the webrtc audio isn't working for both of them.

After updating both systems to version 10.13.1 (17B48) of High Sierra (the update also updated the Safari Technology Preview to version 43 at the same time)

The one with Safari Technology Preview installed. The webrtc audio is working again (both for the regular Safari and the Safari Technology Preview) and the other without Safari Technology Preview the audio in webrtc is still not working.

After installing Safari Technology Preview verion 43 on the one without Safari Technology Preview. The webrtc audio is working again both for the regular Safari and the Safari Technology Preview.

So It looks like Safari Technology Preview version 43 fixes the webrtc audio issue for both the regular Safari and the Safari Technology Preview.

For testing we used:
https://webrtc.github.io/samples/src/content/getusermedia/volume/
https://appr.tc
Comment 10 youenn fablet 2019-06-12 13:08:18 PDT
Closing the bug as this is probably not applicable anymore.
Please reopen if needed.