Bug 178050 - Use one virtual allocation for all gigacages and their runways
Summary: Use one virtual allocation for all gigacages and their runways
Status: RESOLVED DUPLICATE of bug 177586
Alias: None
Product: WebKit
Classification: Unclassified
Component: bmalloc (show other bugs)
Version: WebKit Nightly Build
Hardware: All All
: P2 Normal
Assignee: Filip Pizlo
URL:
Keywords: InRadar
Depends on: 178182
Blocks: 174917
  Show dependency treegraph
 
Reported: 2017-10-07 09:51 PDT by Filip Pizlo
Modified: 2017-10-12 09:02 PDT (History)
5 users (show)

See Also:


Attachments
wip (16.36 KB, patch)
2017-10-07 14:00 PDT, Filip Pizlo
no flags Details | Formatted Diff | Diff
the patch (16.57 KB, patch)
2017-10-07 17:52 PDT, Filip Pizlo
no flags Details | Formatted Diff | Diff
the patch (16.40 KB, patch)
2017-10-07 19:01 PDT, Filip Pizlo
no flags Details | Formatted Diff | Diff
the patch (16.19 KB, patch)
2017-10-07 20:33 PDT, Filip Pizlo
no flags Details | Formatted Diff | Diff
the patch (16.22 KB, patch)
2017-10-07 20:34 PDT, Filip Pizlo
sbarati: review+
Details | Formatted Diff | Diff
patch for landing (16.87 KB, patch)
2017-10-09 20:43 PDT, Filip Pizlo
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Filip Pizlo 2017-10-07 09:51:32 PDT
Patch forthcoming.
Comment 1 Filip Pizlo 2017-10-07 14:00:08 PDT
Created attachment 323101 [details]
wip
Comment 2 Filip Pizlo 2017-10-07 17:52:04 PDT
Created attachment 323109 [details]
the patch
Comment 3 Filip Pizlo 2017-10-07 19:01:37 PDT
Created attachment 323114 [details]
the patch
Comment 4 Filip Pizlo 2017-10-07 20:33:31 PDT
Created attachment 323118 [details]
the patch
Comment 5 Filip Pizlo 2017-10-07 20:34:47 PDT
Created attachment 323119 [details]
the patch
Comment 6 Build Bot 2017-10-08 01:14:35 PDT
Attachment 323119 [details] did not pass style-queue:


ERROR: Source/bmalloc/bmalloc/CryptoRandom.cpp:26:  Found header this file implements before WebCore config.h. Should be: config.h, primary header, blank line, and then alphabetically sorted.  [build/include_order] [4]
Total errors found: 1 in 7 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 7 Filip Pizlo 2017-10-09 20:43:12 PDT
Created attachment 323280 [details]
patch for landing
Comment 8 Build Bot 2017-10-09 20:44:50 PDT
Attachment 323280 [details] did not pass style-queue:


ERROR: Source/bmalloc/bmalloc/CryptoRandom.cpp:26:  Found header this file implements before WebCore config.h. Should be: config.h, primary header, blank line, and then alphabetically sorted.  [build/include_order] [4]
Total errors found: 1 in 8 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 9 Filip Pizlo 2017-10-09 21:28:36 PDT
Landed in https://trac.webkit.org/changeset/223121/webkit
Comment 10 Radar WebKit Bug Importer 2017-10-09 21:29:39 PDT
<rdar://problem/34902910>
Comment 11 WebKit Commit Bot 2017-10-11 12:31:22 PDT
Re-opened since this is blocked by bug 178182
Comment 12 Filip Pizlo 2017-10-12 09:02:38 PDT

*** This bug has been marked as a duplicate of bug 177586 ***