Bug 177792 - A JSFunction's ObjectAllocationProfile should watch the poly prototype watchpoint so it can clear its object allocation profile
Summary: A JSFunction's ObjectAllocationProfile should watch the poly prototype watchp...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Saam Barati
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2017-10-02 16:11 PDT by Saam Barati
Modified: 2017-11-15 09:43 PST (History)
13 users (show)

See Also:


Attachments
patch (9.20 KB, patch)
2017-10-10 19:59 PDT, Saam Barati
ysuzuki: review+
Details | Formatted Diff | Diff
patch for landing (9.09 KB, patch)
2017-11-08 14:17 PST, Saam Barati
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Saam Barati 2017-10-02 16:11:49 PDT
...
Comment 1 Saam Barati 2017-10-10 19:03:41 PDT
patch forthcoming
Comment 2 Saam Barati 2017-10-10 19:59:19 PDT
Created attachment 323373 [details]
patch
Comment 3 Yusuke Suzuki 2017-10-12 01:13:18 PDT
Comment on attachment 323373 [details]
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=323373&action=review

r=me

> Source/JavaScriptCore/runtime/FunctionRareData.h:114
> +    class ClearAllocationProfile : public Watchpoint {

How about naming it ClearAllocationProfileWatchpoint?
Comment 4 Saam Barati 2017-11-08 10:58:20 PST
Thanks for the review. I forgot about this patch. Will land it today with your naming suggestion.
Comment 5 Saam Barati 2017-11-08 14:12:19 PST
Comment on attachment 323373 [details]
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=323373&action=review

>> Source/JavaScriptCore/runtime/FunctionRareData.h:114
>> +    class ClearAllocationProfile : public Watchpoint {
> 
> How about naming it ClearAllocationProfileWatchpoint?

I'm actually thinking that "AllocationProfileClearingWatchpoint" is a better name and more in line with our other names, like, StructureStubInfoClearingWatchpoint.
Comment 6 Saam Barati 2017-11-08 14:17:52 PST
Created attachment 326372 [details]
patch for landing
Comment 7 WebKit Commit Bot 2017-11-08 15:38:59 PST
Comment on attachment 326372 [details]
patch for landing

Clearing flags on attachment: 326372

Committed r224603: <https://trac.webkit.org/changeset/224603>
Comment 8 WebKit Commit Bot 2017-11-08 15:39:00 PST
All reviewed patches have been landed.  Closing bug.
Comment 9 Yusuke Suzuki 2017-11-08 17:57:09 PST
Comment on attachment 323373 [details]
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=323373&action=review

>>> Source/JavaScriptCore/runtime/FunctionRareData.h:114
>>> +    class ClearAllocationProfile : public Watchpoint {
>> 
>> How about naming it ClearAllocationProfileWatchpoint?
> 
> I'm actually thinking that "AllocationProfileClearingWatchpoint" is a better name and more in line with our other names, like, StructureStubInfoClearingWatchpoint.

That sounds nice!
Comment 10 Radar WebKit Bug Importer 2017-11-15 09:43:06 PST
<rdar://problem/35562300>