Bug 177585 - Overlapping text on all CSS fonts specs
Summary: Overlapping text on all CSS fonts specs
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Antti Koivisto
URL:
Keywords: InRadar
: 173876 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-09-27 18:50 PDT by Myles C. Maxfield
Modified: 2019-10-21 11:22 PDT (History)
11 users (show)

See Also:


Attachments
Reproduction (215.57 KB, image/png)
2017-09-27 18:50 PDT, Myles C. Maxfield
no flags Details
Test reduction (132 bytes, text/html)
2017-10-16 11:59 PDT, zalan
no flags Details
patch (5.11 KB, patch)
2017-10-18 06:56 PDT, Antti Koivisto
no flags Details | Formatted Diff | Diff
patch (5.14 KB, patch)
2017-10-18 07:03 PDT, Antti Koivisto
dbates: review+
buildbot: commit-queue-
Details | Formatted Diff | Diff
Archive of layout-test-results from ews125 for ios-simulator-wk2 (1016.36 KB, application/zip)
2017-10-18 08:41 PDT, Build Bot
no flags Details
patch (5.93 KB, patch)
2017-10-19 04:09 PDT, Antti Koivisto
no flags Details | Formatted Diff | Diff
patch (5.93 KB, patch)
2017-10-19 04:11 PDT, Antti Koivisto
commit-queue: commit-queue-
Details | Formatted Diff | Diff
patch (5.93 KB, patch)
2017-10-19 05:32 PDT, Antti Koivisto
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Myles C. Maxfield 2017-09-27 18:50:13 PDT
Created attachment 322054 [details]
Reproduction

See sidebar on https://drafts.csswg.org/css-fonts-4
Comment 1 Radar WebKit Bug Importer 2017-09-27 18:50:51 PDT
<rdar://problem/34704078>
Comment 2 jasbir 2017-10-10 23:37:09 PDT
How to resolve it in Safari 11.
Comment 3 zalan 2017-10-16 11:59:45 PDT
Created attachment 323924 [details]
Test reduction
Comment 4 zalan 2017-10-16 13:33:05 PDT
style().computedLineHeight() looks unresolved (value of 1)
Comment 5 zalan 2017-10-16 18:17:45 PDT
<details><summary></summary></details><li>foobar</li>

1. <li> has rem based line-height.
2. CSS_REMS is resolved using conversionData.rootStyle()
3. CSSToLengthConversionData uses StyleResolver's m_rootElementStyle
-
4. The <details>'s element shadow tree triggers scoping (TreeResolver::pushScope())
5. While popping the scope, we also clear the scope's styleResolver's m_rootElementStyle (TreeResolver::popScope)
6. Since we reuse the style resolver, this reset affects style resolving of the elements outside of the shadow tree. (the <li> element) -> see #1.
Comment 6 Antti Koivisto 2017-10-18 06:56:56 PDT
Created attachment 324113 [details]
patch
Comment 7 Antti Koivisto 2017-10-18 07:03:44 PDT
Created attachment 324114 [details]
patch
Comment 8 Build Bot 2017-10-18 08:41:55 PDT
Comment on attachment 324114 [details]
patch

Attachment 324114 [details] did not pass ios-sim-ews (ios-simulator-wk2):
Output: http://webkit-queues.webkit.org/results/4902386

New failing tests:
fast/shadow-dom/copy-shadow-tree.html
Comment 9 Build Bot 2017-10-18 08:41:57 PDT
Created attachment 324118 [details]
Archive of layout-test-results from ews125 for ios-simulator-wk2

The attached test failures were seen while running run-webkit-tests on the ios-sim-ews.
Bot: ews125  Port: ios-simulator-wk2  Platform: Mac OS X 10.12.6
Comment 10 Daniel Bates 2017-10-18 10:05:30 PDT
Comment on attachment 324114 [details]
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=324114&action=review

> LayoutTests/fast/html/details-line-height-overlap-expected.html:1
> +<html>

Is it necessary to use quirks mode to render this file? Also, the markup in this document is not well-formed. Is this intentional? If we do not need quirks mode then please add <!DOCTYPE html>.

> LayoutTests/fast/html/details-line-height-overlap.html:1
> +<html>

Ditto.
Comment 11 Antti Koivisto 2017-10-18 11:12:04 PDT
(In reply to Build Bot from comment #8)
> Comment on attachment 324114 [details]
> patch
> 
> Attachment 324114 [details] did not pass ios-sim-ews (ios-simulator-wk2):
> Output: http://webkit-queues.webkit.org/results/4902386
> 
> New failing tests:
> fast/shadow-dom/copy-shadow-tree.html

Don't know why this is showing up, it appears to be skipped for all platforms.
Comment 12 Alexey Proskuryakov 2017-10-18 11:29:27 PDT
> Don't know why this is showing up, it appears to be skipped for all platforms.

All tests in this directory are overridden in iOS test expectations as passing, see LayoutTests/platform/ios/TestExpectations:347

webkit.org/b/148695 fast/shadow-dom [ Pass ]

Looks like that tests used to pass before this patch!
Comment 13 Simon Fraser (smfr) 2017-10-18 11:37:35 PDT
 46$ $ ./Tools/Scripts/run-webkit-tests fast/shadow-dom/copy-shadow-tree.html --ios-simulator --print-expectations
Found 1 test; running 1, skipping 0.

Tests to run (1)
fast/shadow-dom/copy-shadow-tree.html  ['PASS'] LayoutTests/platform/ios/TestExpectations:347 webkit.org/b/148695 fast/shadow-dom [ Pass ]
Comment 14 Antti Koivisto 2017-10-19 04:09:40 PDT
Created attachment 324217 [details]
patch
Comment 15 Antti Koivisto 2017-10-19 04:11:35 PDT
Created attachment 324218 [details]
patch
Comment 16 WebKit Commit Bot 2017-10-19 05:20:42 PDT
Comment on attachment 324218 [details]
patch

Rejecting attachment 324218 [details] from commit-queue.

Failed to run "['/Volumes/Data/EWS/WebKit/Tools/Scripts/webkit-patch', '--status-host=webkit-queues.webkit.org', '--bot-id=webkit-cq-02', 'validate-changelog', '--check-oops', '--non-interactive', 324218, '--port=mac']" exit_code: 1 cwd: /Volumes/Data/EWS/WebKit

Dan Bates found in /Volumes/Data/EWS/WebKit/LayoutTests/ChangeLog does not appear to be a valid reviewer according to contributors.json.
/Volumes/Data/EWS/WebKit/LayoutTests/ChangeLog neither lists a valid reviewer nor contains the string "Unreviewed" or "Rubber stamp" (case insensitive).

Full output: http://webkit-queues.webkit.org/results/4918685
Comment 17 Antti Koivisto 2017-10-19 05:32:09 PDT
Created attachment 324221 [details]
patch
Comment 18 WebKit Commit Bot 2017-10-19 06:11:09 PDT
Comment on attachment 324221 [details]
patch

Clearing flags on attachment: 324221

Committed r223688: <https://trac.webkit.org/changeset/223688>
Comment 19 WebKit Commit Bot 2017-10-19 06:11:11 PDT
All reviewed patches have been landed.  Closing bug.
Comment 20 Simon Fraser (smfr) 2019-10-21 11:22:35 PDT
*** Bug 173876 has been marked as a duplicate of this bug. ***