Make StoredCredentials an enum class and rename its header for clarity. This was error-prone because 0 meant "allow" and and 1 meant "do not allow". It was trivial to convert it to a boolean by mistake and get the opposite behavior.
Created attachment 321720 [details]
Comment on attachment 321720 [details]
Clearing flags on attachment: 321720
Committed r222467: <http://trac.webkit.org/changeset/222467>
All reviewed patches have been landed. Closing bug.
Forgot enum *class*.
Created attachment 321830 [details]
Comment on attachment 321830 [details]
Clearing flags on attachment: 321830
Committed r222519: <http://trac.webkit.org/changeset/222519>