Bug 17648 - size attribute of SELECT element
: size attribute of SELECT element
Status: RESOLVED DUPLICATE of bug 28900
Product: WebKit
Classification: Unclassified
Component: Forms
: 528+ (Nightly build)
: All All
: P2 Normal
Assigned To: Nobody
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-03 02:07 PST by Nilesh Patil
Modified: 2011-08-06 18:04 PDT (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nilesh Patil 2008-03-03 02:07:45 PST
WebKit Port : GTK
WebKit Release : 30707

Enter URL : http://www.w3.org/MarkUp/Test/HTML401/current/tests/17_6-BF-01.html
Comment 1 Alexey Proskuryakov 2008-03-03 12:10:53 PST
This is an intentional feature which improves usability; see <http://trac.webkit.org/projects/webkit/browser/trunk/WebCore/rendering/RenderListBox.cpp#L207>.
Comment 2 Matt Lilek (pewtermoose) 2008-03-03 20:45:46 PST
*** Bug 17661 has been marked as a duplicate of this bug. ***
Comment 3 Blake Sening 2008-11-19 09:49:26 PST
No, this is a left alone problem that decreases usability.

If a webpage author wants to set his <select> box size to something smaller than 4, that's what he wants.

Please fix this!!!
Comment 4 Blake Sening 2008-11-19 09:53:52 PST
The Chromium Bug is: 
http://code.google.com/p/chromium/issues/detail?id=4579
Comment 5 Brian 2010-07-08 20:08:35 PDT
This is what you intend?  This makes NO sense!  Because of this behavior, I can not use the select control where I want to on my page because I can not afford the unnecessary vertical space. What possible advantage can there be to the user (me) he wants 2 or 3, and he gets 4?  If I want 4, can't I ask for 4?  THIS MAKES NO SENSE! What are you thinking?  "This is an intentional feature which improves usability"?  How?!  Your link only confirms that the behavior is intended; it doesn't explain how it "improves usability."  And, no explanation is possible.

Use CSS?  So far, I don't see how to duplicate the functionality; but even if that's possible, this should be FIXED!
Comment 6 Daniel 2010-09-15 14:29:37 PDT
Why Webkit Why

the standard states how the select box should behave. anything other than this is not standards compliant.

sometimes  a size of 2 or 3 is needed. 
but you just say "sorry we know what you want better than you do so tough" 

yes i know that size 2 is broken in geko based browsers (scrollbar dissapears) but its still closer to standard compliant than forcing the size to 4
Comment 7 quenenni 2011-06-09 14:44:22 PDT
"This is an intentional feature which improves usability"!!
that's just unbelievable!

frankly, you really think we are going to believe you?
that's just insulting..

well done to turn your incapacity into a "new feature".. wow.. you're great devs..

shame on you
Comment 8 Alexey Proskuryakov 2011-08-06 18:02:45 PDT
Duping to a newer bug that has more progress and no unhelpful comments.
Comment 9 Alexey Proskuryakov 2011-08-06 18:04:17 PDT

*** This bug has been marked as a duplicate of bug 28900 ***