Bug 176442 - [Win] Tools/TestWebKitAPI/Tests/WTF/PriorityQueue.cpp fails to compile with MSVC 2015
Summary: [Win] Tools/TestWebKitAPI/Tests/WTF/PriorityQueue.cpp fails to compile with M...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
: 175706 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-09-05 23:07 PDT by Yoshiaki Jitsukawa
Modified: 2017-09-27 12:51 PDT (History)
7 users (show)

See Also:


Attachments
Patch (3.88 KB, patch)
2017-09-05 23:18 PDT, Yoshiaki Jitsukawa
no flags Details | Formatted Diff | Diff
Patch take 2 (4.27 KB, patch)
2017-09-05 23:37 PDT, Yoshiaki Jitsukawa
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yoshiaki Jitsukawa 2017-09-05 23:07:48 PDT
Currently Tools/TestWebKitAPI/Tests/WTF/PriorityQueue.cpp fails to compile with MSVC 2015.
Comment 1 Yoshiaki Jitsukawa 2017-09-05 23:18:20 PDT
Created attachment 319986 [details]
Patch

Trying to fix build with MSVC 2015. I'm not sure how long this version will be supported but, seeing webkitdirs.pm, looks like it's still supported now.
Comment 2 Keith Miller 2017-09-05 23:22:40 PDT
Comment on attachment 319986 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=319986&action=review

Looks pretty good to me. Minor nit though.

> Tools/TestWebKitAPI/Tests/WTF/PriorityQueue.cpp:59
> +#if defined(_MSC_VER) && _MSC_VER < 1910 // FIXME: Remove this after we stop supporting MSVC 2015.

Can you file a bugzilla for this and link to it in your FIXMEs?
Comment 3 Fujii Hironori 2017-09-05 23:31:50 PDT
*** Bug 175706 has been marked as a duplicate of this bug. ***
Comment 4 Yoshiaki Jitsukawa 2017-09-05 23:32:58 PDT
(In reply to Keith Miller from comment #2)
> Comment on attachment 319986 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=319986&action=review
> 
> Looks pretty good to me. Minor nit though.
> 
> > Tools/TestWebKitAPI/Tests/WTF/PriorityQueue.cpp:59
> > +#if defined(_MSC_VER) && _MSC_VER < 1910 // FIXME: Remove this after we stop supporting MSVC 2015.
> 
> Can you file a bugzilla for this and link to it in your FIXMEs?

Thank you for your suggestion. I've filed Bug 176443.
Comment 5 Keith Miller 2017-09-05 23:36:04 PDT
(In reply to Yoshiaki Jitsukawa from comment #4)
> (In reply to Keith Miller from comment #2)
> > Comment on attachment 319986 [details]
> > Patch
> > 
> > View in context:
> > https://bugs.webkit.org/attachment.cgi?id=319986&action=review
> > 
> > Looks pretty good to me. Minor nit though.
> > 
> > > Tools/TestWebKitAPI/Tests/WTF/PriorityQueue.cpp:59
> > > +#if defined(_MSC_VER) && _MSC_VER < 1910 // FIXME: Remove this after we stop supporting MSVC 2015.
> > 
> > Can you file a bugzilla for this and link to it in your FIXMEs?
> 
> Thank you for your suggestion. I've filed Bug 176443.

Great, thanks! Can you update your patch to link to your bug too?
Comment 6 Yoshiaki Jitsukawa 2017-09-05 23:37:09 PDT
Created attachment 319987 [details]
Patch take 2
Comment 7 Keith Miller 2017-09-05 23:41:02 PDT
Comment on attachment 319987 [details]
Patch take 2

r=me.
Comment 8 WebKit Commit Bot 2017-09-06 00:23:41 PDT
Comment on attachment 319987 [details]
Patch take 2

Clearing flags on attachment: 319987

Committed r221666: <http://trac.webkit.org/changeset/221666>
Comment 9 WebKit Commit Bot 2017-09-06 00:23:43 PDT
All reviewed patches have been landed.  Closing bug.
Comment 10 Radar WebKit Bug Importer 2017-09-27 12:51:11 PDT
<rdar://problem/34694142>