Bug 175987 - Manage tests which require different device types better
Summary: Manage tests which require different device types better
Status: RESOLVED CONFIGURATION CHANGED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2017-08-25 09:15 PDT by Jonathan Bedard
Modified: 2019-06-13 13:09 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Bedard 2017-08-25 09:15:50 PDT
There are a number of problems with layout tests which require different device types.  Currently, iOS Simulator test runs handle this by running the test suite first with 5s devices, then with iPads and then with iPhone 7s.  This is super inefficient since we boot up an entire new queue of devices  (on our bots, this means 12 devices) to run maybe a half-dozen to two-dozen tests.  When running layout tests on actual iOS devices, the problem is even worse.  Currently, we need to skip any device specific test no mater what type of device is connected.  We need to re-factor the way we handle these types of tests.
Comment 1 Radar WebKit Bug Importer 2017-08-25 09:16:10 PDT
<rdar://problem/34082632>
Comment 2 Jonathan Bedard 2017-08-25 09:25:44 PDT
Gardened test for on-device testing in <https://trac.webkit.org/changeset/221188/webkit>.
Comment 3 Jonathan Bedard 2019-06-13 13:09:29 PDT
We implemented this when implementing better support for iPad testing.