Bug 175985 - [GTK] WebProcess from WebKitGtk+ 2.17.91 SIGSEVs in WebCore::ScriptedAnimationController::addThrottlingReason(WebCore::ScriptedAnimationController::ThrottlingReason) at Source/WebCore/dom/ScriptedAnimationController.cpp:134
Summary: [GTK] WebProcess from WebKitGtk+ 2.17.91 SIGSEVs in WebCore::ScriptedAnimatio...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-25 06:56 PDT by Andres Gomez Garcia
Modified: 2018-04-26 05:23 PDT (History)
2 users (show)

See Also:


Attachments
BT from gdb for the WebProcess (151.56 KB, text/plain)
2017-08-25 06:56 PDT, Andres Gomez Garcia
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andres Gomez Garcia 2017-08-25 06:56:38 PDT
Created attachment 319076 [details]
BT from gdb for the WebProcess

I'm using WebKitGtk+ with my own JHBuild setting:
https://github.com/tanty/jhbuild-epiphany/tree/master

Epiphany 3.24.1 and WebKit 2.17.91.

The compilation was done with CMake args:

'-DDEBUG_FISSION=OFF -DPORT=GTK -DCMAKE_BUILD_TYPE=Release -DENABLE_MINIBROWSER=ON -DCMAKE_C_FLAGS_RELEASE="-O0 -g -DNDEBUG -DG_DISABLE_CAST_CHECKS" -DCMAKE_CXX_FLAGS_RELEASE="-O0 -g -DNDEBUG -DG_DISABLE_CAST_CHECKS"'

After visiting:
https://www.instagram.com/p/BYI2imtl6hq/

WebProcess hits a SIGSEV.

This bug is not reproducible in a predictable way.
Comment 1 Adrian Perez 2018-04-25 17:14:17 PDT
The page from the URL does not seem to exist anymore, I get a 404
page. The format of the URL looks like a photo page, like for
example https://www.instagram.com/p/BgaIMVMjZB1/

Browsing Instagram and opening/closing photos for a while seems to
work fine with WebKitGTK+ 2.20.1 + Epiphany 3.28.1.1 (no SIGSEGVs).

Andrés, can you still reproduce the issue?
Comment 2 Andres Gomez Garcia 2018-04-26 05:23:35 PDT
Not since quite a while ...