Bug 175943 - Web Inspector: Table grid shouldn't show behind empty state
Summary: Web Inspector: Table grid shouldn't show behind empty state
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: WebKit Nightly Build
Hardware: Macintosh All
: P2 Normal
Assignee: Devin Rousso
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2017-08-24 11:45 PDT by Alan Sien Wei Hshieh
Modified: 2017-08-24 13:19 PDT (History)
5 users (show)

See Also:


Attachments
Screenshot of the empty state (69.79 KB, image/png)
2017-08-24 11:45 PDT, Alan Sien Wei Hshieh
no flags Details
Patch (1.59 KB, patch)
2017-08-24 12:39 PDT, Devin Rousso
no flags Details | Formatted Diff | Diff
[Image] After Patch is applied (264.75 KB, image/png)
2017-08-24 12:39 PDT, Devin Rousso
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alan Sien Wei Hshieh 2017-08-24 11:45:24 PDT
Created attachment 318999 [details]
Screenshot of the empty state

Currently, when a table is showing an empty state, such as "No Recording Data", grid lines show behind the empty state. This doesn't make sense because the table has no contents. As a result, the grid is just making the empty state less legible. We should show the usual white background behind the empty state so that the "No Recording Data", or similar, empty state is more legible.

Steps to reproduce:

1. Go to Recordings with no recording data
2. Look in the recording data (left) sidebar


Results:

There are alternating row grid lines behind the empty state label. The background should just be a solid color.
Comment 1 Devin Rousso 2017-08-24 12:39:36 PDT
Created attachment 319009 [details]
Patch
Comment 2 Devin Rousso 2017-08-24 12:39:52 PDT
Created attachment 319010 [details]
[Image] After Patch is applied
Comment 3 Brian Burg 2017-08-24 12:44:55 PDT
Comment on attachment 319009 [details]
Patch

r=me
Comment 4 WebKit Commit Bot 2017-08-24 13:18:18 PDT
Comment on attachment 319009 [details]
Patch

Clearing flags on attachment: 319009

Committed r221157: <http://trac.webkit.org/changeset/221157>
Comment 5 WebKit Commit Bot 2017-08-24 13:18:20 PDT
All reviewed patches have been landed.  Closing bug.
Comment 6 Radar WebKit Bug Importer 2017-08-24 13:19:01 PDT
<rdar://problem/34065426>