Bug 175939 - ASSERTION FAILED: !((anchorType == PositionIsBeforeChildren || anchorType == PositionIsAfterChildren) && (is<Text>(*m_anchorNode) || editingIgnoresContent(*m_anchorNode)))
Summary: ASSERTION FAILED: !((anchorType == PositionIsBeforeChildren || anchorType == ...
Status: RESOLVED DUPLICATE of bug 175923
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Wenson Hsieh
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-24 09:39 PDT by Ryan Haddad
Modified: 2017-08-26 15:16 PDT (History)
2 users (show)

See Also:


Attachments
crash log (115.78 KB, text/plain)
2017-08-24 09:39 PDT, Ryan Haddad
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Haddad 2017-08-24 09:39:32 PDT
Created attachment 318994 [details]
crash log

This assertion failure is seen with LayoutTest editing/execCommand/forward-delete-read-write-canvas.html

https://build.webkit.org/results/Apple%20iOS%2010%20Simulator%20Debug%20WK2%20(Tests)/r221132%20(3507)/results.html

ASSERTION FAILED: !((anchorType == PositionIsBeforeChildren || anchorType == PositionIsAfterChildren) && (is<Text>(*m_anchorNode) || editingIgnoresContent(*m_anchorNode)))
/Volumes/Data/slave/ios-simulator-10-debug/build/Source/WebCore/dom/Position.cpp(121) : WebCore::Position::Position(WebCore::Node *, WebCore::Position::AnchorType)
1   0x116d3418d WTFCrash
2   0x11bf9032b WebCore::Position::Position(WebCore::Node*, WebCore::Position::AnchorType)
3   0x11bf90363 WebCore::Position::Position(WebCore::Node*, WebCore::Position::AnchorType)
4   0x10c30863a WebCore::firstPositionInNode(WebCore::Node*)
5   0x10c97fe5e WebKit::WebPage::platformEditorState(WebCore::Frame&, WebKit::EditorState&, WebKit::WebPage::IncludePostLayoutDataHint) const
6   0x10c9248c9 WebKit::WebPage::editorState(WebKit::WebPage::IncludePostLayoutDataHint) const
7   0x10c924e3a WebKit::WebPage::sendPartialEditorStateAndSchedulePostLayoutUpdate()
8   0x10c9392fc WebKit::WebPage::didChangeSelection()
9   0x10c983a46 WebKit::WebPage::updateSelectionAppearance()
10  0x10c844882 WebKit::WebFrameLoaderClient::dispatchDidLayout()
11  0x11aa3e7c9 WebCore::FrameView::performPostLayoutTasks()
12  0x11aa453c3 WebCore::FrameView::layout(bool)
13  0x11a667be7 WebCore::Document::updateLayout()
14  0x11a66cdbe WebCore::Document::updateLayoutIgnorePendingStylesheets(WebCore::Document::RunPostLayoutTasks)
15  0x11a7d9886 WebCore::Editor::Command::execute(WTF::String const&, WebCore::Event*) const
16  0x11a681289 WebCore::Document::execCommand(WTF::String const&, bool, WTF::String const&)
17  0x11b1a5de9 WebCore::jsDocumentPrototypeFunctionExecCommandBody(JSC::ExecState*, WebCore::JSDocument*, JSC::ThrowScope&)
18  0x11b191f4e long long WebCore::IDLOperation<WebCore::JSDocument>::call<&(WebCore::jsDocumentPrototypeFunctionExecCommandBody(JSC::ExecState*, WebCore::JSDocument*, JSC::ThrowScope&)), (WebCore::CastedThisErrorBehavior)0>(JSC::ExecState&, char const*)
19  0x11b191cdc WebCore::jsDocumentPrototypeFunctionExecCommand(JSC::ExecState*)
20  0x35cf9967028
21  0x1169a0d16 llint_entry
22  0x1169990e7 vmEntryToJavaScript
23  0x1167859ce JSC::JITCode::execute(JSC::VM*, JSC::ProtoCallFrame*)
24  0x116734a88 JSC::Interpreter::executeProgram(JSC::SourceCode const&, JSC::ExecState*, JSC::JSObject*)
25  0x1160c2088 JSC::evaluate(JSC::ExecState*, JSC::SourceCode const&, JSC::JSValue, WTF::NakedPtr<JSC::Exception>&)
26  0x1160c2250 JSC::profiledEvaluate(JSC::ExecState*, JSC::ProfilingReason, JSC::SourceCode const&, JSC::JSValue, WTF::NakedPtr<JSC::Exception>&)
27  0x11c445b6b WebCore::JSMainThreadExecState::profiledEvaluate(JSC::ExecState*, JSC::ProfilingReason, JSC::SourceCode const&, JSC::JSValue, WTF::NakedPtr<JSC::Exception>&)
28  0x11c445958 WebCore::ScriptController::evaluateInWorld(WebCore::ScriptSourceCode const&, WebCore::DOMWrapperWorld&, WebCore::ExceptionDetails*)
29  0x11c445c4d WebCore::ScriptController::evaluate(WebCore::ScriptSourceCode const&, WebCore::ExceptionDetails*)
30  0x11c45aae2 WebCore::ScriptElement::executeClassicScript(WebCore::ScriptSourceCode const&)
31  0x11c4590ef WebCore::ScriptElement::prepareScript(WTF::TextPosition const&, WebCore::ScriptElement::LegacyTypeSupport)
LEAK: 1 WebPageProxy
Comment 1 Ryan Haddad 2017-08-24 09:40:04 PDT
This is seen on iOS Simulator Debug WK2 bots
Comment 2 Ryan Haddad 2017-08-24 09:43:12 PDT
Skipped test in https://trac.webkit.org/r221140
Comment 3 Alexey Proskuryakov 2017-08-26 15:16:48 PDT

*** This bug has been marked as a duplicate of bug 175923 ***