Bug 175797 - Add UIDelegatePrivate SPI corresponding to WKPageUIClient.showPage
Summary: Add UIDelegatePrivate SPI corresponding to WKPageUIClient.showPage
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Alex Christensen
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2017-08-21 17:10 PDT by Alex Christensen
Modified: 2017-08-23 10:28 PDT (History)
6 users (show)

See Also:


Attachments
Patch (15.95 KB, patch)
2017-08-21 17:19 PDT, Alex Christensen
no flags Details | Formatted Diff | Diff
Patch (18.07 KB, patch)
2017-08-22 14:45 PDT, Alex Christensen
no flags Details | Formatted Diff | Diff
Patch (17.41 KB, patch)
2017-08-22 15:05 PDT, Alex Christensen
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Christensen 2017-08-21 17:10:25 PDT
Add UIDelegatePrivate SPI corresponding to WKPageUIClient.showPage
Comment 1 Alex Christensen 2017-08-21 17:19:16 PDT
Created attachment 318703 [details]
Patch
Comment 2 Geoffrey Garen 2017-08-22 10:16:20 PDT
Comment on attachment 318703 [details]
Patch

r=me
Comment 3 WebKit Commit Bot 2017-08-22 11:12:13 PDT
Comment on attachment 318703 [details]
Patch

Clearing flags on attachment: 318703

Committed r221026: <http://trac.webkit.org/changeset/221026>
Comment 4 WebKit Commit Bot 2017-08-22 11:12:15 PDT
All reviewed patches have been landed.  Closing bug.
Comment 5 Radar WebKit Bug Importer 2017-08-22 11:13:25 PDT
<rdar://problem/34016741>
Comment 6 Matt Lewis 2017-08-22 14:09:46 PDT
This caused an api timeout with the test WebKit2.ShowPage on iOS Simulators

https://build.webkit.org/builders/Apple%20iOS%2010%20Simulator%20Release%20WK2%20%28Tests%29/builds/3781/steps/run-api-tests/logs/stdio
Comment 7 Matt Lewis 2017-08-22 14:10:17 PDT
Reverted r221026 for reason:

This caused a consistent API failure on iOS Simulator.

Committed r221047: <http://trac.webkit.org/changeset/221047>
Comment 8 Alex Christensen 2017-08-22 14:45:13 PDT
Created attachment 318802 [details]
Patch
Comment 9 Alex Christensen 2017-08-22 15:05:33 PDT
Created attachment 318804 [details]
Patch
Comment 10 Alex Christensen 2017-08-22 16:15:19 PDT
http://trac.webkit.org/r221055
Comment 11 Tim Horton 2017-08-22 16:20:50 PDT
What's up with the icky name?
Comment 12 Alex Christensen 2017-08-23 10:10:15 PDT
_webViewClose corresponds with WKPageUIClient.close.  I figured _webViewShow was a good name for a function that corresponds with WKPageUIClient.showPage.  All the other methods in UIDelegatePrivate start with _webView...
Comment 13 Tim Horton 2017-08-23 10:28:08 PDT
(In reply to Alex Christensen from comment #12)
> _webViewClose corresponds with WKPageUIClient.close.  I figured _webViewShow
> was a good name for a function that corresponds with
> WKPageUIClient.showPage. 

You figured incorrectly :)

It should at a /minimum/ be -(void)_showWebView:(WKWebView *)webView. Please fix!

> All the other methods in UIDelegatePrivate start
> with _webView...

Not true.