Bug 17570 - 307 Temporary Redirect not handled correctly for HTTP POST
Summary: 307 Temporary Redirect not handled correctly for HTTP POST
Status: RESOLVED DUPLICATE of bug 11118
Alias: None
Product: WebKit
Classification: Unclassified
Component: Page Loading (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-02-27 10:48 PST by Brad Kish
Modified: 2008-02-27 11:50 PST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brad Kish 2008-02-27 10:48:09 PST
If a 307 Temporary Redirect is received in response to a POST, the browser should attempt to repeat the POST at the new temporary location. The user should be notified and allowed to abort this redirect.

Currently a 307 is being treated like a 302 or 303 where it changes the method of the original request and uses a GET on the new temporary location.

This is status code is handled by other modern browsers.
Comment 1 Mark Rowe (bdash) 2008-02-27 11:50:30 PST

*** This bug has been marked as a duplicate of 11118 ***