Bug 175641 - REGRESSION(r220751): [GTK] Layout Test imported/w3c/web-platform-tests/fetch/api/basic/scheme-about.any.html is failing
Summary: REGRESSION(r220751): [GTK] Layout Test imported/w3c/web-platform-tests/fetch/...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Ms2ger (he/him; ⌚ UTC+1/+2)
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2017-08-16 15:38 PDT by Alicia Boya García
Modified: 2017-08-17 05:42 PDT (History)
6 users (show)

See Also:


Attachments
Patch (2.17 KB, patch)
2017-08-17 00:50 PDT, Ms2ger (he/him; ⌚ UTC+1/+2)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alicia Boya García 2017-08-16 15:38:02 PDT
The following layout test is failing on WebKitGTK.

imported/w3c/web-platform-tests/fetch/api/basic/scheme-about.any.html

Probable cause:

GTK expectations were not updated.
Comment 1 Alicia Boya García 2017-08-16 15:57:56 PDT
I thought it could be because of outdated expectations because of a very similar difference between the output and the current GTK expectation and the output and the current general expectation, but those differences turned out to be in different lines of the test output. 

It looks more like the wrong error is being thrown.
Comment 2 Michael Catanzaro 2017-08-16 17:46:36 PDT
Alicia, can you submit a patch updating the GTK test expectations to reflect this failure? The expectation should contain a link to this bug, and this bug should be left open until the test is fixed.
Comment 3 Ms2ger (he/him; ⌚ UTC+1/+2) 2017-08-17 00:50:17 PDT
Created attachment 318336 [details]
Patch
Comment 4 Konstantin Tokarev 2017-08-17 02:42:58 PDT
Comment on attachment 318336 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=318336&action=review

> LayoutTests/platform/gtk/imported/w3c/web-platform-tests/fetch/api/basic/scheme-about.any-expected.txt:9
> +FAIL Fetching about:blank (PUT) is OK promise_test: Unhandled rejection with value: object "TypeError: The URL canât be shown"

"can't" maybe?
Comment 5 Ms2ger (he/him; ⌚ UTC+1/+2) 2017-08-17 03:35:41 PDT
(In reply to Konstantin Tokarev from comment #4)
> Comment on attachment 318336 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=318336&action=review
> 
> > LayoutTests/platform/gtk/imported/w3c/web-platform-tests/fetch/api/basic/scheme-about.any-expected.txt:9
> > +FAIL Fetching about:blank (PUT) is OK promise_test: Unhandled rejection with value: object "TypeError: The URL canât be shown"
> 
> "can't" maybe?

Someone decided to embed a "smart quote" in the error message, I'm afraid.
Comment 6 Michael Catanzaro 2017-08-17 05:12:22 PDT
See https://developer.gnome.org/hig/stable/typography.html.en for guidance on use of smart quotes. (Use them!)

Our patch review tool is broken for mangling Unicode.
Comment 7 WebKit Commit Bot 2017-08-17 05:41:36 PDT
Comment on attachment 318336 [details]
Patch

Clearing flags on attachment: 318336

Committed r220853: <http://trac.webkit.org/changeset/220853>
Comment 8 WebKit Commit Bot 2017-08-17 05:41:37 PDT
All reviewed patches have been landed.  Closing bug.
Comment 9 Radar WebKit Bug Importer 2017-08-17 05:42:20 PDT
<rdar://problem/33938735>