Bug 17558 - Rollover links work but image swaps do not.
Summary: Rollover links work but image swaps do not.
Status: CLOSED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://beatricehamblett.com
Keywords:
Depends on:
Blocks:
 
Reported: 2008-02-26 14:31 PST by David DelMonte
Modified: 2008-02-26 17:22 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David DelMonte 2008-02-26 14:31:58 PST
This may be a Safari problem. 

I can reproduce the problem in the following sites:

http://beatricehamblett.com - all links and buttons are supposed to change color on rollover.
http://studiospark.com - click "about us" then "our team" - the images are supposed to change on rollover.
http://www.harnesselwayarts.com/index.php - the colors of the names of the artists should change
Comment 1 Mark Rowe (bdash) 2008-02-26 15:25:04 PST
These all work fine for me in Safari 3.0.4 and latest WebKit builds.  What version of WebKit are you using?  Do you have JavaScript enabled in Safari?
Comment 2 David DelMonte 2008-02-26 16:34:51 PST
Thanks for the response Mark. I just updated Safari 3.0.4 and the links work for me as well. I'm under NDA with Apple so this may well be a Safari specific problem, or some interaction between the two.

For the record, Javascript is enabled. I'm using the Webkit from last night (r30595).

David
Comment 3 Mark Rowe (bdash) 2008-02-26 16:50:27 PST
Which combination of WebKit and Safari are you experiencing the problem with?  You state that it works in Safari 3.0.4, is that with WebKit r30595?
Comment 4 David DelMonte 2008-02-26 17:03:50 PST
That is correct. The sites function ok with Safari 3.0.4 and Webkit r30595.

I'm new at reporting problems here. I don't know the interaction between webkit.org and Apple. The reason for reporting the problem here is that there may be a problem in the interaction between the current Webkit build and unannounced Apple software.

Hopefully I'm not off the NDA.
Comment 5 Mark Rowe (bdash) 2008-02-26 17:06:30 PST
> That is correct. The sites function ok with Safari 3.0.4 and Webkit r30595.

If the site functions correctly with the latest WebKit build then I'm not at all sure what it is you're reporting.  If you are observing problems in a piece of Apple software covered by an NDA you should be reporting bugs against it via the appropriate forum:  either http://bugreport.apple.com/ or another location that would be mentioned when downloading said software.

Closing bug due to comment that it functions correctly, and my inability to reproduce any incorrect behaviour.
Comment 6 David DelMonte 2008-02-26 17:15:41 PST
This is interesting.. I didn't think Firefox used Webkit. But I get the following results.

In FF 3 beta 3, where I also have installed Safari 3.0.4 and Webkit r30395, FF works fine.

Using the same program on the computer where my NDA program is located, FF also does not work properly.

David
Comment 7 Matt Lilek 2008-02-26 17:18:31 PST
(In reply to comment #6)
> This is interesting.. I didn't think Firefox used Webkit. But I get the
> following results.
> 
> In FF 3 beta 3, where I also have installed Safari 3.0.4 and Webkit r30395, FF
> works fine.
> 
> Using the same program on the computer where my NDA program is located, FF also
> does not work properly.
> 
> David
> 

Firefox doesn't use WebKit.  The fact that both browsers exhibit the same issue means that it's an issue with that machine.
Comment 8 David DelMonte 2008-02-26 17:22:18 PST
OK. I will agree with that assessment.

Thanks for walking me through the troubleshooting.

David