Bug 17552 - SVG images not working as background-image
Summary: SVG images not working as background-image
Status: RESOLVED DUPLICATE of bug 21910
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-02-26 05:55 PST by Sjoerd Tieleman (tieleman)
Modified: 2008-12-30 21:20 PST (History)
2 users (show)

See Also:


Attachments
Example HTML file (379 bytes, text/html)
2008-02-26 05:56 PST, Sjoerd Tieleman (tieleman)
no flags Details
Example SVG file (580 bytes, image/svg+xml)
2008-02-26 05:56 PST, Sjoerd Tieleman (tieleman)
no flags Details
standalone test case (2.42 KB, text/html)
2008-03-20 00:58 PDT, Robert Blaut
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sjoerd Tieleman (tieleman) 2008-02-26 05:55:37 PST
It appears that SVG images are currently not working as a background image. See attached examples.
HTML file contains a div which should have a SVG as a background-image (CSS). Supplied SVG image does work when simply used in an img tag.
Comment 1 Sjoerd Tieleman (tieleman) 2008-02-26 05:56:12 PST
Created attachment 19372 [details]
Example HTML file
Comment 2 Sjoerd Tieleman (tieleman) 2008-02-26 05:56:45 PST
Created attachment 19373 [details]
Example SVG file
Comment 3 Robert Blaut 2008-03-18 16:37:13 PDT
Confirmed in Webkit r31132 on Mac OS X 10.5.
Comment 4 Robert Blaut 2008-03-20 00:58:46 PDT
Created attachment 19894 [details]
standalone test case

This test works out of box.
Comment 5 Simon Fraser (smfr) 2008-12-30 21:20:17 PST

*** This bug has been marked as a duplicate of 21910 ***