Bug 175480 - [GTK] Update some test expectations.
Summary: [GTK] Update some test expectations.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Ms2ger (he/him; ⌚ UTC+1/+2)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-11 08:09 PDT by Ms2ger (he/him; ⌚ UTC+1/+2)
Modified: 2017-08-14 01:28 PDT (History)
4 users (show)

See Also:


Attachments
Patch (5.16 KB, patch)
2017-08-11 08:11 PDT, Ms2ger (he/him; ⌚ UTC+1/+2)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ms2ger (he/him; ⌚ UTC+1/+2) 2017-08-11 08:09:13 PDT
.
Comment 1 Ms2ger (he/him; ⌚ UTC+1/+2) 2017-08-11 08:11:54 PDT
Created attachment 317930 [details]
Patch
Comment 2 Michael Catanzaro 2017-08-11 08:23:30 PDT
Comment on attachment 317930 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=317930&action=review

> LayoutTests/platform/gtk/imported/w3c/web-platform-tests/html/semantics/selectors/pseudo-classes/inrange-outofrange-expected.txt:7
> +FAIL ':in-range' matches all elements that are candidates for constraint validation, have range limitations, and that are neither suffering from an underflow nor suffering from an overflow assert_array_equals: lengths differ, expected 10 got 5
> +FAIL ':out-of-range' matches all elements that are candidates for constraint validation, have range limitations, and that are either suffering from an underflow or suffering from an overflow assert_array_equals: lengths differ, expected 12 got 2
> +FAIL ':in-range' update number1's value < min assert_array_equals: lengths differ, expected 9 got 4
> +FAIL ':out-of-range' update number1's value < min assert_array_equals: lengths differ, expected 13 got 3
> +FAIL ':in-range' update number3's min < value assert_array_equals: lengths differ, expected 10 got 5
> +FAIL ':out-of-range' update number3's min < value assert_array_equals: lengths differ, expected 12 got 2

Why is this expected behavior?
Comment 3 Ms2ger (he/him; ⌚ UTC+1/+2) 2017-08-11 08:29:54 PDT
That's actually kind of odd. The only difference between this file and the platform-neutral expectation file is the whitespace at the end. I have no idea where it comes from.
Comment 4 Michael Catanzaro 2017-08-11 08:42:54 PDT
OK, then it's fine. Youenn accepts lots of FAILS is our web platform tests expectations since it's still useful to catch unexpected behavior changes. I'd just prefer to not have them in GTK-specific expectations as that's not how we track bugs on our port.
Comment 5 WebKit Commit Bot 2017-08-14 01:28:18 PDT
Comment on attachment 317930 [details]
Patch

Clearing flags on attachment: 317930

Committed r220655: <http://trac.webkit.org/changeset/220655>
Comment 6 WebKit Commit Bot 2017-08-14 01:28:19 PDT
All reviewed patches have been landed.  Closing bug.