Bug 175448 - Web Inspector: add filter for draw actions in Recordings
Summary: Web Inspector: add filter for draw actions in Recordings
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: WebKit Nightly Build
Hardware: All All
: P2 Normal
Assignee: Devin Rousso
URL:
Keywords: InRadar
Depends on: 174484
Blocks: WebInspectorCanvasRecording
  Show dependency treegraph
 
Reported: 2017-08-10 15:08 PDT by Devin Rousso
Modified: 2017-08-24 17:57 PDT (History)
7 users (show)

See Also:


Attachments
Patch (10.21 KB, patch)
2017-08-23 14:43 PDT, Devin Rousso
no flags Details | Formatted Diff | Diff
[Image] After Patch is applied (359.67 KB, image/png)
2017-08-23 14:44 PDT, Devin Rousso
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Devin Rousso 2017-08-10 15:08:18 PDT
We are already able to filter by name, but we currently can't filter by "designation"/"category".  Filtering by whether the action draws would be great.  This could be done similar to how Debugger has "Only show resources with issues".
Comment 1 Radar WebKit Bug Importer 2017-08-23 12:12:13 PDT
<rdar://problem/34040764>
Comment 2 Devin Rousso 2017-08-23 14:43:46 PDT
Created attachment 318923 [details]
Patch
Comment 3 Devin Rousso 2017-08-23 14:44:12 PDT
Created attachment 318924 [details]
[Image] After Patch is applied
Comment 4 Matt Baker 2017-08-23 15:33:45 PDT
We should remove the visual change highlight when the filter is active.
Comment 5 Devin Rousso 2017-08-23 15:45:43 PDT
(In reply to Matt Baker from comment #4)
> We should remove the visual change highlight when the filter is active.
I think that would be more confusing.  I would expect filtering to just show/hide, not change any shown UI.
Comment 6 Matt Baker 2017-08-24 15:19:48 PDT
Comment on attachment 318923 [details]
Patch

r=me, just need to figure out what's causing the build failure on wpe.
Comment 7 Matt Baker 2017-08-24 16:27:30 PDT
The problem is with the way WPE handles dependencies.

WebKit/PlatformWPE.cmake:435:
set(InspectorFiles
    ${CMAKE_SOURCE_DIR}/Source/WebInspectorUI/Localizations/en.lproj/localizedStrings.js
    ${CMAKE_SOURCE_DIR}/Source/WebInspectorUI/UserInterface/*.html
    ${CMAKE_SOURCE_DIR}/Source/WebInspectorUI/UserInterface/Base/*.js
    ${CMAKE_SOURCE_DIR}/Source/WebInspectorUI/UserInterface/Controllers/*.css
    ${CMAKE_SOURCE_DIR}/Source/WebInspectorUI/UserInterface/Controllers/*.js
    ${CMAKE_SOURCE_DIR}/Source/WebInspectorUI/UserInterface/Debug/*.css
    ${CMAKE_SOURCE_DIR}/Source/WebInspectorUI/UserInterface/Debug/*.js
    ${CMAKE_SOURCE_DIR}/Source/WebInspectorUI/UserInterface/External/CodeMirror/*.css
    ${CMAKE_SOURCE_DIR}/Source/WebInspectorUI/UserInterface/External/CodeMirror/*.js
    ${CMAKE_SOURCE_DIR}/Source/WebInspectorUI/UserInterface/External/ESLint/*.js
    ${CMAKE_SOURCE_DIR}/Source/WebInspectorUI/UserInterface/External/Esprima/*.js
    ${CMAKE_SOURCE_DIR}/Source/WebInspectorUI/UserInterface/Images/gtk/*.png
    ${CMAKE_SOURCE_DIR}/Source/WebInspectorUI/UserInterface/Images/gtk/*.svg
    ${CMAKE_SOURCE_DIR}/Source/WebInspectorUI/UserInterface/Models/*.js
    ${CMAKE_SOURCE_DIR}/Source/WebInspectorUI/UserInterface/Protocol/*.js
    ${CMAKE_SOURCE_DIR}/Source/WebInspectorUI/UserInterface/Proxies/*.js
    ${CMAKE_SOURCE_DIR}/Source/WebInspectorUI/UserInterface/Test/*.js
    ${CMAKE_SOURCE_DIR}/Source/WebInspectorUI/UserInterface/Views/*.css
    ${CMAKE_SOURCE_DIR}/Source/WebInspectorUI/UserInterface/Views/*.js
    ${CMAKE_SOURCE_DIR}/Source/WebInspectorUI/UserInterface/Workers/Formatter/*.js
    ${CMAKE_SOURCE_DIR}/Source/WebInspectorUI/UserInterface/Workers/HeapSnapshot/*.js
)

file(GLOB InspectorFilesDependencies
    ${InspectorFiles}
)

InspectorGResourceBundle.xml is only regenerated when CMake runs, which will be never, since CMakeLists.txt isn't changing. WPE will break whenever an Inspector file is renamed, and won't pick up newly added files either.
Comment 8 Matt Baker 2017-08-24 17:28:16 PDT
This is a known issue, and I've contacted a couple of WPE maintainers to remind them. Since this just effects EWS, no need to wait for a resolution.
Comment 9 WebKit Commit Bot 2017-08-24 17:57:45 PDT
Comment on attachment 318923 [details]
Patch

Clearing flags on attachment: 318923

Committed r221174: <http://trac.webkit.org/changeset/221174>
Comment 10 WebKit Commit Bot 2017-08-24 17:57:46 PDT
All reviewed patches have been landed.  Closing bug.