Bug 17509 - Acid3 expects different exceptions for surroundContents calls involving comment nodes (affects Acid3 test 11)
: Acid3 expects different exceptions for surroundContents calls involving comme...
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: XML DOM
: 528+ (Nightly build)
: All All
: P2 Normal
Assigned To: Maciej Stachowiak
:
Depends on:
Blocks: Acid3
  Show dependency treegraph
 
Reported: 2008-02-24 01:01 PST by Darin Adler
Modified: 2008-03-16 20:51 PDT (History)
0 users

See Also:


Attachments
the fix (7.65 KB, patch)
2008-03-16 20:26 PDT, Maciej Stachowiak
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Darin Adler 2008-02-24 01:01:21 PST
This looks like low-hanging fruit to me. Should be easy to fix.
Comment 1 Darin Adler 2008-02-25 15:57:00 PST
I started working on this and I think it's not as easy as I initially thought. The problem is that we need to check all the children that will be put inside the new element to see if they are types that are allowed. The code isn't structured to make that easy. It still looks *relatively* straightforward, but I would no longer say easy.
Comment 2 Maciej Stachowiak 2008-03-16 20:26:36 PDT
Created attachment 19822 [details]
the fix
Comment 3 Darin Adler 2008-03-16 20:31:49 PDT
Comment on attachment 19822 [details]
the fix

r=me