Bug 174950 - Multiple API failures on all testers with URLSchemeHandler and IconLoading
Summary: Multiple API failures on all testers with URLSchemeHandler and IconLoading
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Brady Eidson
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2017-07-28 14:23 PDT by Matt Lewis
Modified: 2017-07-31 15:50 PDT (History)
4 users (show)

See Also:


Attachments
Patch (6.30 KB, patch)
2017-07-28 15:36 PDT, Brady Eidson
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Lewis 2017-07-28 14:23:04 PDT
After the revision https://trac.webkit.org/changeset/220011/webkit

There were multiple failures in API tests for all testers involving these tests:

  IconLoading.AlreadyCachedIcon
  IconLoading.DefaultFavicon
  IconLoading.IconLoadCancelledCallback
  IconLoading.IconLoadCancelledCallback2
  URLSchemeHandler.Basic
  URLSchemeHandler.Exceptions
  URLSchemeHandler.NoMIMEType
  URLSchemeHandler.Redirection

Build Results:
https://build.webkit.org/builders/Apple%20El%20Capitan%20Release%20WK1%20(Tests)/builds/3595/steps/run-api-tests/logs/stdio
https://build.webkit.org/builders/Apple%20El%20Capitan%20Release%20WK1%20(Tests)/builds/3595
Comment 1 Brady Eidson 2017-07-28 14:42:49 PDT
These tests are actually completing successfully, then hanging during test tear down.
Comment 2 Brady Eidson 2017-07-28 15:13:03 PDT
A very simple fix makes 7 of these work.

Exploring what's up with NoMIMEType now...
Comment 3 Brady Eidson 2017-07-28 15:27:44 PDT
(In reply to Brady Eidson from comment #2)
> A very simple fix makes 7 of these work.
> 
> Exploring what's up with NoMIMEType now...

Answer - The test is bogus!
Comment 4 Brady Eidson 2017-07-28 15:36:37 PDT
Created attachment 316679 [details]
Patch
Comment 5 WebKit Commit Bot 2017-07-28 16:19:53 PDT
Comment on attachment 316679 [details]
Patch

Clearing flags on attachment: 316679

Committed r220033: <http://trac.webkit.org/changeset/220033>
Comment 6 WebKit Commit Bot 2017-07-28 16:19:55 PDT
All reviewed patches have been landed.  Closing bug.
Comment 7 Radar WebKit Bug Importer 2017-07-28 16:43:47 PDT
<rdar://problem/33601794>
Comment 8 Matt Lewis 2017-07-31 10:06:47 PDT
The API test URLSchemeHandler.Exceptions is still failing unexpectedly on Mac Debug testers.

Sierra WK2:
https://build.webkit.org/builders/Apple%20Sierra%20Debug%20WK2%20%28Tests%29/builds/2281
Sierra WK1:
https://build.webkit.org/builders/Apple%20Sierra%20Debug%20WK1%20%28Tests%29/builds/2703

El Capitan WK2:
https://build.webkit.org/builders/Apple%20El%20Capitan%20Debug%20WK2%20%28Tests%29/builds/2334

El Capitan WK1:
https://build.webkit.org/builders/Apple%20El%20Capitan%20Debug%20WK1%20%28Tests%29/builds/2716

It is flaky on iOS Debug often passing when the test URLSchemeHandler.Leaks1 times out.


The error given is:
UNEXPECTEDLY EXITED URLSchemeHandler.Exceptions
2017-07-31 06:21:28.036 TestWebKitAPI[59294:40826290] -[NSError init] called; this results in an invalid NSError instance. It will raise an exception in a future release. Please call errorWithDomain:code:userInfo: or initWithDomain:code:userInfo:. This message shown only once.
Comment 9 Matt Lewis 2017-07-31 10:17:05 PDT
After further digging and talking with Brady, the Leaks1 does not look to be related as the test was added after the others.

In addition this shows Exception failing when Leaks1 times out:
https://build.webkit.org/builders/Apple%20iOS%2010%20Simulator%20Debug%20WK2%20(Tests)/builds/3024
Comment 10 Brady Eidson 2017-07-31 15:50:20 PDT
(In reply to Matt Lewis from comment #8)
> The API test URLSchemeHandler.Exceptions is still failing unexpectedly on
> Mac Debug testers.
> 
> 
> The error given is:
> UNEXPECTEDLY EXITED URLSchemeHandler.Exceptions
> 2017-07-31 06:21:28.036 TestWebKitAPI[59294:40826290] -[NSError init]
> called; this results in an invalid NSError instance. It will raise an
> exception in a future release. Please call errorWithDomain:code:userInfo: or
> initWithDomain:code:userInfo:. This message shown only once.

The [NSError init] is (probably) irrelevant.

The test is crashing.

I installed a fresh install of Sierra 10.12.4 and did a clean debug build of ToT WebKit and cannot reproduce this problem.

Could you dig up a crash log?

Also, let's move to a new bug - There's absolutely no indication that the bug originally reported here is *not* fixed.

The bots are seeing something different.