RESOLVED WORKSFORME 174873
Dashboard: Add displayName property in BuildbotQueue
https://bugs.webkit.org/show_bug.cgi?id=174873
Summary Dashboard: Add displayName property in BuildbotQueue
Aakash Jain
Reported 2017-07-26 14:21:43 PDT
BuildbotQueue has an 'id', which serves two purposes: 1) used as an id in URLs. 2) used as a display name in dashboard. We should separate out these two use-cases. buildbot 0.9 have separate values for 'name' and 'id'. 'id' are integers in buildbot 0.9. This change will ease the buildbot 0.9 support.
Attachments
Proposed patch (7.16 KB, patch)
2017-07-26 16:03 PDT, Aakash Jain
no flags
Aakash Jain
Comment 1 2017-07-26 16:03:47 PDT
Created attachment 316495 [details] Proposed patch
Alexey Proskuryakov
Comment 2 2017-07-27 13:39:35 PDT
Comment on attachment 316495 [details] Proposed patch View in context: https://bugs.webkit.org/attachment.cgi?id=316495&action=review > Tools/ChangeLog:3 > + Dashboard: Add displayName property in BuildbotQueue How is this different from the existing "heading" property?
Aakash Jain
Comment 3 2017-07-27 13:56:21 PDT
> How is this different from the existing "heading" property? Heading seems to be the high level category of the builder, example of few headings: "Production", "Debug", "Performance". displayName is the complete name of the builder, e.g: "Apple El Capitan Release WK1 (Tests)". Currently we are using 'id' in the places where this patch use displayName. This was fine in buildbot 0.8 since displayName can be used as an id. However, in buildbot 0.9 name and id are separate.
Alexey Proskuryakov
Comment 4 2017-07-27 14:07:47 PDT
I don't think that's all there is to it. See e.g. this part of WebKitBuildbot.js: "Apple El Capitan JSC": {platform: Dashboard.Platform.MacOSXElCapitan, heading: "JavaScript", combinedQueues: { "Apple El Capitan 32-bit JSC (BuildAndTest)": {heading: "32-bit JSC (BuildAndTest)"}, ... Perhaps heading is only implemented for combined queues at this time?
Aakash Jain
Comment 5 2017-07-27 14:50:08 PDT
> Perhaps heading is only implemented for combined queues at this time? Yeah, heading seems to be defined for some of the queues (24 out of ~50 queues in WebKitBuild.js), and for many of queues it is just one-word. The purpose of this patch is to ensure that the variable 'id' is used only as an 'id' (e.g.: in URLs for REST API). 'id' should not be used as a display name. This would simplify the support for buildbot 0.9, in which id is an integer. This point came up in discussion with Dan Bates, in order to avoid adding a new variable 'builderid' in BuildbotQueue in https://bugs.webkit.org/attachment.cgi?id=316276&action=review
Alexey Proskuryakov
Comment 6 2017-07-27 17:45:52 PDT
Anyway, my comment is that given that heading is currently used in the same way as opposed displayName, I think that we shouldn't be using two properties with different names. I haven't looked into any other aspects of the patch.
Aakash Jain
Comment 7 2017-07-27 20:01:51 PDT
In further discussions with Dan Bates, we figured out a better way to handle buildbot 0.9 support which doesn't require this change.
Note You need to log in before you can comment on or make changes to this bug.