Bug 174758 - [iOS WK2] Remove _WKDraggableElementInfo and fold PositionInformationTests into WKRequestActivatedElementInfo
Summary: [iOS WK2] Remove _WKDraggableElementInfo and fold PositionInformationTests in...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Wenson Hsieh
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-22 20:10 PDT by Wenson Hsieh
Modified: 2017-07-24 10:25 PDT (History)
5 users (show)

See Also:


Attachments
Patch (37.26 KB, patch)
2017-07-22 20:45 PDT, Wenson Hsieh
mitz: review+
Details | Formatted Diff | Diff
Patch for landing (37.26 KB, patch)
2017-07-22 21:50 PDT, Wenson Hsieh
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Wenson Hsieh 2017-07-22 20:10:55 PDT
_WKDraggableElementInfo is no longer used anywhere in WebKit, so it should be removed. However, some edge cases in PositionInformationTests that currently use _WKDraggableElementInfo are still useful tests to keep around, so fold them into the WKRequestActivatedElementInfo test suite.
Comment 1 Wenson Hsieh 2017-07-22 20:45:21 PDT
Created attachment 316222 [details]
Patch
Comment 2 mitz 2017-07-22 21:01:42 PDT
Comment on attachment 316222 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=316222&action=review

> Tools/TestWebKitAPI/cocoa/TestWKWebView.h:56
> +- (_WKActivatedElementInfo *)_activatedElementAtPosition:(CGPoint)position;

Probably don’t need the underscore prefix on this method’s name. It’s like the rest of the TestWKWebView methods.
Comment 3 Wenson Hsieh 2017-07-22 21:43:05 PDT
(In reply to mitz from comment #2)
> Comment on attachment 316222 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=316222&action=review
> 
> > Tools/TestWebKitAPI/cocoa/TestWKWebView.h:56
> > +- (_WKActivatedElementInfo *)_activatedElementAtPosition:(CGPoint)position;
> 
> Probably don’t need the underscore prefix on this method’s name. It’s like
> the rest of the TestWKWebView methods.

Good catch -- fixed. I originally had it as SPI on WKWebView, and then decided to move it into TestWebKitAPI but didn't rename it.

Thanks for the review!
Comment 4 Wenson Hsieh 2017-07-22 21:50:58 PDT
Created attachment 316224 [details]
Patch for landing
Comment 5 WebKit Commit Bot 2017-07-22 22:28:37 PDT
Comment on attachment 316224 [details]
Patch for landing

Clearing flags on attachment: 316224

Committed r219768: <http://trac.webkit.org/changeset/219768>