Bug 173967 - REGRESSION(r215347): NAS4Free Pop-down menus fail to appear
Summary: REGRESSION(r215347): NAS4Free Pop-down menus fail to appear
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2017-06-29 06:24 PDT by Antti Koivisto
Modified: 2017-06-29 09:10 PDT (History)
5 users (show)

See Also:


Attachments
patch (3.96 KB, patch)
2017-06-29 06:33 PDT, Antti Koivisto
kling: review+
Details | Formatted Diff | Diff
patch (5.74 KB, patch)
2017-06-29 07:02 PDT, Antti Koivisto
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Antti Koivisto 2017-06-29 06:24:35 PDT
Visibility change on non-composited layer should trigger layer geometry update.
Comment 1 Antti Koivisto 2017-06-29 06:25:07 PDT
<rdar://problem/32690114>
Comment 2 Antti Koivisto 2017-06-29 06:33:39 PDT
Created attachment 314130 [details]
patch
Comment 3 Andreas Kling 2017-06-29 06:42:55 PDT
Comment on attachment 314130 [details]
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=314130&action=review

r=me

> Source/WebCore/ChangeLog:3
> +        NAS4Free Pop-down menus take 3 seconds to appear

Maybe you could tell us a bit more about this? Since you brought it up, I mean.. If you hadn't, I would have accepted the patch as-is.

> Source/WebCore/ChangeLog:16
> +            Trigger compositing update for non-composited layers on visibility change.

Like you suggested on IRC, it would be nice to factor these checks out into a helper function.
Comment 4 Antti Koivisto 2017-06-29 07:02:09 PDT
Created attachment 314132 [details]
patch
Comment 5 Simon Fraser (smfr) 2017-06-29 08:15:09 PDT
Comment on attachment 314132 [details]
patch

Looks OK.
Comment 6 WebKit Commit Bot 2017-06-29 09:10:14 PDT
Comment on attachment 314132 [details]
patch

Clearing flags on attachment: 314132

Committed r218925: <http://trac.webkit.org/changeset/218925>
Comment 7 WebKit Commit Bot 2017-06-29 09:10:16 PDT
All reviewed patches have been landed.  Closing bug.