Bug 173610 - Set getUserMedia permission to true by default on WTR
Summary: Set getUserMedia permission to true by default on WTR
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: youenn fablet
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-20 11:37 PDT by youenn fablet
Modified: 2017-06-23 16:16 PDT (History)
3 users (show)

See Also:


Attachments
Patch (11.66 KB, patch)
2017-06-20 11:39 PDT, youenn fablet
no flags Details | Formatted Diff | Diff
Fixing name (11.60 KB, patch)
2017-06-20 22:11 PDT, youenn fablet
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description youenn fablet 2017-06-20 11:37:26 PDT
This will ease running WPT tests
Comment 1 youenn fablet 2017-06-20 11:39:19 PDT
Created attachment 313416 [details]
Patch
Comment 2 Eric Carlson 2017-06-20 18:58:01 PDT
Comment on attachment 313416 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=313416&action=review

> Tools/WebKitTestRunner/InjectedBundle/InjectedBundle.cpp:607
> +void InjectedBundle::setUserMediaPermissionAsUnset()

Nit: maybe “reserUserMediaPermission” instead?
Comment 3 youenn fablet 2017-06-20 19:42:59 PDT
(In reply to Eric Carlson from comment #2)
> Comment on attachment 313416 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=313416&action=review
> 
> > Tools/WebKitTestRunner/InjectedBundle/InjectedBundle.cpp:607
> > +void InjectedBundle::setUserMediaPermissionAsUnset()
> 
> Nit: maybe “reserUserMediaPermission” instead?

setUserMediaPermissionAsUnset is indeed a poor name.
How about unsetUserMediaPermission?
Comment 4 Eric Carlson 2017-06-20 21:41:30 PDT
Comment on attachment 313416 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=313416&action=review

>>> Tools/WebKitTestRunner/InjectedBundle/InjectedBundle.cpp:607
>>> +void InjectedBundle::setUserMediaPermissionAsUnset()
>> 
>> Nit: maybe “reserUserMediaPermission” instead?
> 
> setUserMediaPermissionAsUnset is indeed a poor name.
> How about unsetUserMediaPermission?

That is better, but "reset" is probably better than "unset".
Comment 5 youenn fablet 2017-06-20 22:11:22 PDT
Created attachment 313491 [details]
Fixing name
Comment 6 youenn fablet 2017-06-23 13:59:02 PDT
ping review
Comment 7 WebKit Commit Bot 2017-06-23 16:16:35 PDT
Comment on attachment 313491 [details]
Fixing name

Clearing flags on attachment: 313491

Committed r218773: <http://trac.webkit.org/changeset/218773>
Comment 8 WebKit Commit Bot 2017-06-23 16:16:37 PDT
All reviewed patches have been landed.  Closing bug.