Bug 173599 - Accept SharedArrayBuffers in WebGL API
Summary: Accept SharedArrayBuffers in WebGL API
Status: RESOLVED DUPLICATE of bug 223167
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebGL (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2017-06-20 06:54 PDT by oleksandr.chekhovskyi
Modified: 2021-09-09 03:33 PDT (History)
6 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description oleksandr.chekhovskyi 2017-06-20 06:54:25 PDT
Safari has shipped SharedArrayBuffer/Atomics support, but its usefulness for one of the primary use cases (games)
is limited by not being able to use it with WebGL. Firefox and Chrome both allow it.

For a real usage example, see https://statebuilder.com/ (a game I'm developing). It works on both Chrome and Firefox,
but I had to blacklist Safari due to missing WebGL with SAB support. Blacklist can be avoided by setting User-Agent to Chrome.
Comment 1 Radar WebKit Bug Importer 2017-06-22 15:38:32 PDT
<rdar://problem/32934795>
Comment 2 Yusuke Suzuki 2021-09-09 03:33:48 PDT
It is fixed in bug 223167 :)

*** This bug has been marked as a duplicate of bug 223167 ***