Bug 17357 - Google maps tiles fail to appear at certain window sizes
Summary: Google maps tiles fail to appear at certain window sizes
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://maps.google.com/?ie=UTF8&z=11&...
Keywords: GoogleBug, InRadar, NeedsReduction
Depends on:
Blocks:
 
Reported: 2008-02-14 00:34 PST by Eric Seidel (no email)
Modified: 2009-05-13 01:02 PDT (History)
6 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2008-02-14 00:34:40 PST
Google maps tiles fail to appear at certain window sizes

http://maps.google.com/?ie=UTF8&z=11&ll=37.159222,-121.953735&spn=0.402212,0.563049&om=1&layer=t

This can be easily reproduced by loading the above URL and then resizing your window to a small size, then resizing it to a larger size again.  As you drag the window larger missing tiles will draw over the top of the map.  Sometimes when loading the map initially the missing tiles draw over the top of the map to begin with.
Comment 1 Eric Seidel (no email) 2008-02-14 01:34:32 PST
The inspector says the bad tiles in question are "transparent.png"

One example:
<img style="border-top-width: 0px; border-right-width: 0px; border-bottom-width: 0px; border-left-width: 0px; border-style: initial; border-color: initial; padding-top: 0px; padding-right: 0px; padding-bottom: 0px; padding-left: 0px; margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; position: absolute; left: 272px; top: 270px; width: 256px; height: 256px; " src="http://maps.google.com/intl/en_us/mapfiles/transparent.png">

How they get that way... no clue.

Also, why the inspector claims we have loaded lots and lots of the same transparent.png file is unclear to me.  I'm not sure if its an inspector bug what.
Comment 2 Timothy Hatcher 2008-02-14 09:03:29 PST
Back in July 2007, I brought up that Google Maps appears to be checking for Safari and going down a code path that is different from other WebKit based applications like OmniWeb or Dashboard. The bug we are seeing because of this happens when you drag a map around very quickly and the tiles stop updating and just stay gray. Looking at them in the Web Inspector I see that the img elements are not being updated to point to the correct map tile image, but stay pointing at http:&#8203;/&#8203;/&#8203;www.google.com/&#8203;intl/&#8203;en_us/&#8203;mapfiles/&#8203;transparent.png.

What is the issue being worked-around here that you had to special case Safari? Is there a WebKit bug filed about it?

The Safari Google Maps behavior is obviously correct and we would like Google to not check for "Safari" in the user agent string, but instead check for "AppleWebKit". Then users of other WebKit based applications will get the same experience as Safari.

I am not sure if this is what you are seeing or what.
Comment 3 Jacob Hoffman-Andrews 2008-02-15 17:59:01 PST
As of the end of July 2007, Google Maps no longer looks for "safari" but instead "applewebkit".  This can be verified by searching, e.g. http://maps.google.com/mapfiles/99/maps2/main.js for both "safari" and "applewebkit."  So that issue is unrelated to this one.
Comment 4 mitz 2008-03-11 18:12:30 PDT
<rdar://problem/5744860>
Comment 5 Sam Stigler 2009-05-13 00:30:33 PDT
I am unable to reproduce this with WebKit r43605 on Mac OS 10.5.6. I suggest this be marked as closed.
Comment 6 Eric Seidel (no email) 2009-05-13 01:02:16 PDT
I think that google maps has changed.  I no longer am able to reproduce this either.
Comment 7 Eric Seidel (no email) 2009-05-13 01:02:30 PDT
Wrong resolution.