RESOLVED FIXED 173444
[WebIDL] Remove custom bindings for HTMLDocument
https://bugs.webkit.org/show_bug.cgi?id=173444
Summary [WebIDL] Remove custom bindings for HTMLDocument
Sam Weinig
Reported 2017-06-15 16:04:49 PDT
[WebIDL] Remove custom bindings for HTMLDocument
Attachments
Patch (28.31 KB, patch)
2017-06-15 16:18 PDT, Sam Weinig
no flags
Patch (29.92 KB, patch)
2017-06-15 16:23 PDT, Sam Weinig
no flags
Patch (32.64 KB, patch)
2017-06-15 17:05 PDT, Sam Weinig
no flags
Archive of layout-test-results from ews103 for mac-elcapitan (1.12 MB, application/zip)
2017-06-15 18:12 PDT, Build Bot
no flags
Archive of layout-test-results from ews104 for mac-elcapitan-wk2 (1.28 MB, application/zip)
2017-06-15 18:18 PDT, Build Bot
no flags
Archive of layout-test-results from ews122 for ios-simulator-wk2 (932.99 KB, application/zip)
2017-06-15 18:44 PDT, Build Bot
no flags
Archive of layout-test-results from ews113 for mac-elcapitan (1.77 MB, application/zip)
2017-06-15 18:47 PDT, Build Bot
no flags
Patch (54.13 KB, patch)
2017-06-16 09:37 PDT, Sam Weinig
no flags
Archive of layout-test-results from ews102 for mac-elcapitan (640.35 KB, application/zip)
2017-06-16 10:40 PDT, Build Bot
no flags
Archive of layout-test-results from ews105 for mac-elcapitan-wk2 (585.58 KB, application/zip)
2017-06-16 10:44 PDT, Build Bot
no flags
Patch (56.13 KB, patch)
2017-06-16 10:57 PDT, Sam Weinig
no flags
Patch (56.08 KB, patch)
2017-06-16 11:32 PDT, Sam Weinig
no flags
Archive of layout-test-results from ews106 for mac-elcapitan-wk2 (491.11 KB, application/zip)
2017-06-16 12:20 PDT, Build Bot
no flags
Archive of layout-test-results from ews103 for mac-elcapitan (234.34 KB, application/zip)
2017-06-16 12:28 PDT, Build Bot
no flags
Archive of layout-test-results from ews114 for mac-elcapitan (201.79 KB, application/zip)
2017-06-16 12:30 PDT, Build Bot
no flags
Archive of layout-test-results from ews125 for ios-simulator-wk2 (463.23 KB, application/zip)
2017-06-16 12:39 PDT, Build Bot
no flags
Patch (56.16 KB, patch)
2017-06-16 13:05 PDT, Sam Weinig
no flags
Patch (56.15 KB, patch)
2017-06-16 13:57 PDT, Sam Weinig
no flags
Archive of layout-test-results from ews102 for mac-elcapitan (1.01 MB, application/zip)
2017-06-16 15:11 PDT, Build Bot
no flags
Archive of layout-test-results from ews114 for mac-elcapitan (1.90 MB, application/zip)
2017-06-16 15:18 PDT, Build Bot
no flags
Archive of layout-test-results from ews107 for mac-elcapitan-wk2 (1.15 MB, application/zip)
2017-06-16 15:27 PDT, Build Bot
no flags
Archive of layout-test-results from ews121 for ios-simulator-wk2 (13.65 MB, application/zip)
2017-06-16 15:35 PDT, Build Bot
no flags
Patch (61.35 KB, patch)
2017-06-16 16:01 PDT, Sam Weinig
no flags
Archive of layout-test-results from ews103 for mac-elcapitan (1001.11 KB, application/zip)
2017-06-16 17:11 PDT, Build Bot
no flags
Archive of layout-test-results from ews106 for mac-elcapitan-wk2 (1.08 MB, application/zip)
2017-06-16 17:18 PDT, Build Bot
no flags
Archive of layout-test-results from ews113 for mac-elcapitan (1.75 MB, application/zip)
2017-06-16 17:30 PDT, Build Bot
no flags
Archive of layout-test-results from ews123 for ios-simulator-wk2 (923.79 KB, application/zip)
2017-06-16 17:38 PDT, Build Bot
no flags
Sam Weinig
Comment 1 2017-06-15 16:18:05 PDT Comment hidden (obsolete)
Build Bot
Comment 2 2017-06-15 16:20:42 PDT Comment hidden (obsolete)
Sam Weinig
Comment 3 2017-06-15 16:23:43 PDT Comment hidden (obsolete)
Sam Weinig
Comment 4 2017-06-15 17:05:40 PDT Comment hidden (obsolete)
Build Bot
Comment 5 2017-06-15 18:12:05 PDT Comment hidden (obsolete)
Build Bot
Comment 6 2017-06-15 18:12:07 PDT Comment hidden (obsolete)
Build Bot
Comment 7 2017-06-15 18:18:45 PDT Comment hidden (obsolete)
Build Bot
Comment 8 2017-06-15 18:18:46 PDT Comment hidden (obsolete)
Build Bot
Comment 9 2017-06-15 18:44:14 PDT Comment hidden (obsolete)
Build Bot
Comment 10 2017-06-15 18:44:16 PDT Comment hidden (obsolete)
Build Bot
Comment 11 2017-06-15 18:47:40 PDT Comment hidden (obsolete)
Build Bot
Comment 12 2017-06-15 18:47:41 PDT Comment hidden (obsolete)
Sam Weinig
Comment 13 2017-06-16 09:37:04 PDT Comment hidden (obsolete)
Build Bot
Comment 14 2017-06-16 10:40:16 PDT Comment hidden (obsolete)
Build Bot
Comment 15 2017-06-16 10:40:18 PDT Comment hidden (obsolete)
Build Bot
Comment 16 2017-06-16 10:44:32 PDT Comment hidden (obsolete)
Build Bot
Comment 17 2017-06-16 10:44:34 PDT Comment hidden (obsolete)
Sam Weinig
Comment 18 2017-06-16 10:57:45 PDT Comment hidden (obsolete)
Sam Weinig
Comment 19 2017-06-16 11:32:23 PDT Comment hidden (obsolete)
Build Bot
Comment 20 2017-06-16 12:20:44 PDT Comment hidden (obsolete)
Build Bot
Comment 21 2017-06-16 12:20:45 PDT Comment hidden (obsolete)
Build Bot
Comment 22 2017-06-16 12:28:09 PDT Comment hidden (obsolete)
Build Bot
Comment 23 2017-06-16 12:28:10 PDT Comment hidden (obsolete)
Build Bot
Comment 24 2017-06-16 12:30:56 PDT Comment hidden (obsolete)
Build Bot
Comment 25 2017-06-16 12:30:57 PDT Comment hidden (obsolete)
Build Bot
Comment 26 2017-06-16 12:39:00 PDT Comment hidden (obsolete)
Build Bot
Comment 27 2017-06-16 12:39:01 PDT Comment hidden (obsolete)
Sam Weinig
Comment 28 2017-06-16 13:05:52 PDT Comment hidden (obsolete)
Sam Weinig
Comment 29 2017-06-16 13:57:48 PDT
Darin Adler
Comment 30 2017-06-16 14:34:57 PDT
Comment on attachment 313128 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=313128&action=review Would be nice to line up our terminology with the specification even closer. Can we use the term "responsible document" for example? > Source/WebCore/ChangeLog:109 > +2017-06-15 Sam Weinig <sam@webkit.org> Double change log. > Source/WebCore/bindings/scripts/CodeGeneratorJS.pm:5344 > + AddToImplIncludes("Document.h"); Not sure I understand why this is required. > Source/WebCore/bindings/scripts/CodeGeneratorJS.pm:5352 > + AddToImplIncludes("Document.h"); Ditto. > Source/WebCore/dom/Document.cpp:2663 > + return; Should not add this. I assume it’s a leftover from refactoring. > Source/WebCore/dom/Document.cpp:7257 > +void Document::clear() > +{ > + // Per https://html.spec.whatwg.org/multipage/obsolete.html#dom-document-clear, this method does nothing. > +} > + > +void Document::captureEvents() > +{ > + // Per https://html.spec.whatwg.org/multipage/obsolete.html#dom-document-captureevents, this method does nothing. > +} > + > +void Document::releaseEvents() > +{ > + // Per https://html.spec.whatwg.org/multipage/obsolete.html#dom-document-releaseevents, this method does nothing. > +} inline? > Source/WebCore/dom/Document.h:601 > WEBCORE_EXPORT void open(Document* ownerDocument = nullptr); Maybe rename this at some point? Even possible at that time that we might want to rename openForBindings back to open. > Source/WebCore/dom/Document.h:605 > WEBCORE_EXPORT void close(); Maybe rename this at some point? Even possible at that time that we might want to rename closeForBindings back to close. > Source/WebCore/dom/Document.h:1335 > + WEBCORE_EXPORT const AtomicString& linkColorForBindings() const; > + WEBCORE_EXPORT void setLinkColorForBindings(const String&); Do we really need the existing linkColor and setLinkColor? Can we rename those instead?
Build Bot
Comment 31 2017-06-16 15:11:14 PDT Comment hidden (obsolete)
Build Bot
Comment 32 2017-06-16 15:11:16 PDT Comment hidden (obsolete)
Build Bot
Comment 33 2017-06-16 15:18:10 PDT Comment hidden (obsolete)
Build Bot
Comment 34 2017-06-16 15:18:11 PDT Comment hidden (obsolete)
Build Bot
Comment 35 2017-06-16 15:27:39 PDT Comment hidden (obsolete)
Build Bot
Comment 36 2017-06-16 15:27:41 PDT Comment hidden (obsolete)
Build Bot
Comment 37 2017-06-16 15:35:20 PDT Comment hidden (obsolete)
Build Bot
Comment 38 2017-06-16 15:35:22 PDT Comment hidden (obsolete)
Sam Weinig
Comment 39 2017-06-16 15:58:47 PDT
(In reply to Darin Adler from comment #30) > Comment on attachment 313128 [details] > Patch > > View in context: > https://bugs.webkit.org/attachment.cgi?id=313128&action=review > > Would be nice to line up our terminology with the specification even closer. > Can we use the term "responsible document" for example? I renamed CallerDocument to ResponsibleDocument and added a more clear comment. > > > Source/WebCore/ChangeLog:109 > > +2017-06-15 Sam Weinig <sam@webkit.org> > > Double change log. Fixed. > > Source/WebCore/bindings/scripts/CodeGeneratorJS.pm:5344 > > + AddToImplIncludes("Document.h"); > > Not sure I understand why this is required. > > > Source/WebCore/bindings/scripts/CodeGeneratorJS.pm:5352 > > + AddToImplIncludes("Document.h"); > > Ditto. They shouldn't be. Removed. > > > Source/WebCore/dom/Document.cpp:2663 > > + return; > > Should not add this. I assume it’s a leftover from refactoring. Yup. Removed. > > > Source/WebCore/dom/Document.cpp:7257 > > +void Document::clear() > > +{ > > + // Per https://html.spec.whatwg.org/multipage/obsolete.html#dom-document-clear, this method does nothing. > > +} > > + > > +void Document::captureEvents() > > +{ > > + // Per https://html.spec.whatwg.org/multipage/obsolete.html#dom-document-captureevents, this method does nothing. > > +} > > + > > +void Document::releaseEvents() > > +{ > > + // Per https://html.spec.whatwg.org/multipage/obsolete.html#dom-document-releaseevents, this method does nothing. > > +} > > inline? Inlined. > > > Source/WebCore/dom/Document.h:601 > > WEBCORE_EXPORT void open(Document* ownerDocument = nullptr); > > Maybe rename this at some point? Even possible at that time that we might > want to rename openForBindings back to open. > > > Source/WebCore/dom/Document.h:605 > > WEBCORE_EXPORT void close(); > > Maybe rename this at some point? Even possible at that time that we might > want to rename closeForBindings back to close. Added comments. Follow up. > > > Source/WebCore/dom/Document.h:1335 > > + WEBCORE_EXPORT const AtomicString& linkColorForBindings() const; > > + WEBCORE_EXPORT void setLinkColorForBindings(const String&); > > Do we really need the existing linkColor and setLinkColor? Can we rename > those instead? I tried to think of an alternate name for the existing linkColor and came up blank. If I think of one I'll come back and fix it. Thanks for the review!
Sam Weinig
Comment 40 2017-06-16 16:01:07 PDT Comment hidden (obsolete)
Build Bot
Comment 41 2017-06-16 17:11:55 PDT Comment hidden (obsolete)
Build Bot
Comment 42 2017-06-16 17:11:56 PDT Comment hidden (obsolete)
Build Bot
Comment 43 2017-06-16 17:18:30 PDT Comment hidden (obsolete)
Build Bot
Comment 44 2017-06-16 17:18:32 PDT Comment hidden (obsolete)
Build Bot
Comment 45 2017-06-16 17:30:05 PDT Comment hidden (obsolete)
Build Bot
Comment 46 2017-06-16 17:30:07 PDT Comment hidden (obsolete)
Build Bot
Comment 47 2017-06-16 17:38:43 PDT Comment hidden (obsolete)
Build Bot
Comment 48 2017-06-16 17:38:45 PDT Comment hidden (obsolete)
Sam Weinig
Comment 49 2017-06-16 18:19:31 PDT
Frédéric Wang (:fredw)
Comment 50 2018-07-04 02:49:35 PDT
Note You need to log in before you can comment on or make changes to this bug.