RESOLVED FIXED 172688
[WebIDL] Generate named property deleters
https://bugs.webkit.org/show_bug.cgi?id=172688
Summary [WebIDL] Generate named property deleters
Sam Weinig
Reported 2017-05-28 17:43:11 PDT
Its time to generate named property deleters.
Attachments
Test case (1.12 KB, text/html)
2017-05-28 22:07 PDT, Sam Weinig
no flags
Patch (129.60 KB, patch)
2017-05-28 22:30 PDT, Sam Weinig
no flags
Archive of layout-test-results from ews104 for mac-elcapitan-wk2 (1.01 MB, application/zip)
2017-05-28 23:21 PDT, Build Bot
no flags
Archive of layout-test-results from ews103 for mac-elcapitan (953.85 KB, application/zip)
2017-05-28 23:34 PDT, Build Bot
no flags
Archive of layout-test-results from ews117 for mac-elcapitan (1.90 MB, application/zip)
2017-05-28 23:37 PDT, Build Bot
no flags
Archive of layout-test-results from ews124 for ios-simulator-wk2 (10.81 MB, application/zip)
2017-05-29 00:00 PDT, Build Bot
no flags
Patch (135.85 KB, patch)
2017-05-29 11:56 PDT, Sam Weinig
buildbot: commit-queue-
Archive of layout-test-results from ews121 for ios-simulator-wk2 (895.03 KB, application/zip)
2017-05-29 13:25 PDT, Build Bot
no flags
Patch (135.85 KB, patch)
2017-05-29 14:13 PDT, Sam Weinig
cdumez: review+
Sam Weinig
Comment 1 2017-05-28 22:07:37 PDT
Created attachment 311456 [details] Test case Turns out we have some subtle bugs in our current hand rolled implementation (not surprising). Attaching test case showing them.
Sam Weinig
Comment 2 2017-05-28 22:30:02 PDT Comment hidden (obsolete)
Build Bot
Comment 3 2017-05-28 23:21:15 PDT Comment hidden (obsolete)
Build Bot
Comment 4 2017-05-28 23:21:17 PDT Comment hidden (obsolete)
Build Bot
Comment 5 2017-05-28 23:34:01 PDT Comment hidden (obsolete)
Build Bot
Comment 6 2017-05-28 23:34:04 PDT Comment hidden (obsolete)
Build Bot
Comment 7 2017-05-28 23:37:18 PDT Comment hidden (obsolete)
Build Bot
Comment 8 2017-05-28 23:37:19 PDT Comment hidden (obsolete)
Build Bot
Comment 9 2017-05-29 00:00:01 PDT Comment hidden (obsolete)
Build Bot
Comment 10 2017-05-29 00:00:03 PDT Comment hidden (obsolete)
Sam Weinig
Comment 11 2017-05-29 11:56:05 PDT Comment hidden (obsolete)
Build Bot
Comment 12 2017-05-29 13:25:54 PDT Comment hidden (obsolete)
Build Bot
Comment 13 2017-05-29 13:25:55 PDT Comment hidden (obsolete)
Sam Weinig
Comment 14 2017-05-29 14:13:24 PDT
Chris Dumez
Comment 15 2017-05-30 14:01:27 PDT
Comment on attachment 311485 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=311485&action=review > Source/WebCore/bindings/js/JSDOMAbstractOperations.h:38 > +template<bool overrideBuiltins, class JSClass> Could we use an enum class instead of a boolean? I understand this is only used in generated code but the call sites are really not very readable. > Source/WebCore/bindings/scripts/CodeGeneratorJS.pm:822 > + push(@$outputArray, " return !impl.isSupportedPropertyIndex(index.value()) ? true : false;\n"); return !impl.isSupportedPropertyIndex(index.value()); ? Why the ternary? > Source/WebCore/bindings/scripts/CodeGeneratorJS.pm:829 > + # the remained of the algoritm ourselves. typo: algorithm > Source/WebCore/bindings/scripts/CodeGeneratorJS.pm:856 > + push(@$outputArray, " return !impl.isSupportedPropertyIndex(index) ? true : false;\n"); Why the ternary? > Source/WebCore/storage/Storage.h:50 > + // Bindings support functions Missing period at the end
Sam Weinig
Comment 16 2017-05-30 14:34:28 PDT
(In reply to Chris Dumez from comment #15) > Comment on attachment 311485 [details] > Patch > > View in context: > https://bugs.webkit.org/attachment.cgi?id=311485&action=review > > > Source/WebCore/bindings/js/JSDOMAbstractOperations.h:38 > > +template<bool overrideBuiltins, class JSClass> > > Could we use an enum class instead of a boolean? I understand this is only > used in generated code but the call sites are really not very readable. Ok. > > > Source/WebCore/bindings/scripts/CodeGeneratorJS.pm:822 > > + push(@$outputArray, " return !impl.isSupportedPropertyIndex(index.value()) ? true : false;\n"); > > return !impl.isSupportedPropertyIndex(index.value()); ? Why the ternary? Just cause it was how the spec was worded. I'll collapse it. > > > Source/WebCore/bindings/scripts/CodeGeneratorJS.pm:829 > > + # the remained of the algoritm ourselves. > > typo: algorithm Ok. > > Source/WebCore/storage/Storage.h:50 > > + // Bindings support functions > > Missing period at the end Ok.
Sam Weinig
Comment 17 2017-05-30 16:54:53 PDT
Radar WebKit Bug Importer
Comment 18 2017-05-30 20:20:27 PDT
Note You need to log in before you can comment on or make changes to this bug.