Bug 172681 - Missing local-candidate & remote-candidate stats
Summary: Missing local-candidate & remote-candidate stats
Status: RESOLVED DUPLICATE of bug 172734
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2017-05-27 08:03 PDT by Michael Leaney
Modified: 2017-05-30 15:11 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Leaney 2017-05-27 08:03:51 PDT
getStats on a peer connection is missing RTCIceCandidatePairStats and RTCIceCandidateStats objects. local-candidate and remote-candidate are missing. Both Chrome and Firefox provide these, and in particular, we are interested in the priority field as we use it to differentiate between STUN, TURN/TLS, TURN/TCP, TURN/UDP. This is also a requirement from the spec.

Steps to Reproduce:
Head to: https://webrtc.github.io/samples/src/content/peerconnection/constraints/
Click "Get media"
Click "Connect"
Observe there is no local-candidate or remote-candidate stat types

Expected Results:
There are stats for candidate pairs etc. Expect to see RTCIceCandidatePairStats and RTCIceCandidateStats types.

Observed Results:
There is no objects of type RTCIceCandidatePairStats or RTCIceCandidateStats
Comment 1 Radar WebKit Bug Importer 2017-05-27 10:24:57 PDT
<rdar://problem/32443070>
Comment 2 Jon Lee 2017-05-29 15:39:14 PDT
rdar://problem/32368232
Comment 3 youenn fablet 2017-05-30 15:11:59 PDT

*** This bug has been marked as a duplicate of bug 172734 ***