Bug 172650 - Layout test workers/wasm-hashset.html is flaky
Summary: Layout test workers/wasm-hashset.html is flaky
Status: RESOLVED CONFIGURATION CHANGED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Saam Barati
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2017-05-26 10:41 PDT by Matt Lewis
Modified: 2017-11-15 13:11 PST (History)
13 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Lewis 2017-05-26 10:41:43 PDT
workers/wasm-hashset.html is a flaky timeout. 
On the flakiness dashboard the test is timing out on both Mac wk1 debugs and the Sierra WK2 Release.
https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=workers%2Fwasm-hashset.html

currently the test is skipped on iOS and windows.

The test usually runs quickly with a 1-5 second run time but each time the test times out, it runs for 155 seconds.
The test was added with https://trac.webkit.org/changeset/215353/webkit
It was marked as slow in the same revision r215353.

https://build.webkit.org/results/Apple%20El%20Capitan%20Debug%20WK1%20(Tests)/r217490%20(1478)/results.html
https://build.webkit.org/builders/Apple%20El%20Capitan%20Debug%20WK1%20(Tests)/builds/1478
Comment 1 Saam Barati 2017-05-31 14:37:19 PDT
(In reply to Matt Lewis from comment #0)
> workers/wasm-hashset.html is a flaky timeout. 
> On the flakiness dashboard the test is timing out on both Mac wk1 debugs and
> the Sierra WK2 Release.
> https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.
> html#showAllRuns=true&tests=workers%2Fwasm-hashset.html
> 
> currently the test is skipped on iOS and windows.
> 
> The test usually runs quickly with a 1-5 second run time but each time the
> test times out, it runs for 155 seconds.
> The test was added with https://trac.webkit.org/changeset/215353/webkit
> It was marked as slow in the same revision r215353.
> 
> https://build.webkit.org/results/
> Apple%20El%20Capitan%20Debug%20WK1%20(Tests)/r217490%20(1478)/results.html
> https://build.webkit.org/builders/
> Apple%20El%20Capitan%20Debug%20WK1%20(Tests)/builds/1478

Hmm, perhaps it's worth looking into this since the jump from 5 seconds to 155 seconds could implicate a deadlock somewhere. I'll look into it.
Comment 3 JF Bastien 2017-10-24 16:03:17 PDT
Might be unrelated, but my latest checkout has a 100% reproducible debug assert about a refcount somewhere in initNormalWorld's callees. I'll try to bisect to see where that started, it might lead to a release crash in the future.
Comment 4 JF Bastien 2017-10-24 16:25:10 PDT
(In reply to JF Bastien from comment #3)
> Might be unrelated, but my latest checkout has a 100% reproducible debug
> assert about a refcount somewhere in initNormalWorld's callees. I'll try to
> bisect to see where that started, it might lead to a release crash in the
> future.

I think my local build was messed up? Ignore me for now, will report back later...
Comment 5 JF Bastien 2017-10-26 08:25:45 PDT
Did this stop flaking after Saam reverted the bmalloc patch? I don't seem to have access to https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=workers%2Fwasm-hashset.html
Comment 6 Matt Lewis 2017-10-30 12:53:03 PDT
This has since stoped flaking according to the flakiness dashboard.
Comment 7 Radar WebKit Bug Importer 2017-11-15 13:11:59 PST
<rdar://problem/35568980>