Bug 17263 - Acid3 test 80 (linktest onload didn't fire) fails on reload but passes on first run
Summary: Acid3 test 80 (linktest onload didn't fire) fails on reload but passes on fir...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore JavaScript (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://acid3.acidtests.org/
Keywords:
Depends on:
Blocks: Acid3
  Show dependency treegraph
 
Reported: 2008-02-09 14:33 PST by Matt Lilek
Modified: 2008-02-24 01:45 PST (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Lilek 2008-02-09 14:33:27 PST
If you run the Acid 3 test in ToT, you pass 79/100 tests, reloading it and running it again only passes 78/100 tests.  Test 80 (linktest onload didn't fire) does not pass the second time.
Comment 1 Robert Blaut 2008-02-09 15:52:37 PST
Webkit r30109. Tens of Acid3 test runs and I haven't notice 79/100 score at all.
Comment 2 Darin Adler 2008-02-10 12:39:33 PST
I've seen this; we need to investigate.
Comment 3 Dave Hyatt 2008-02-10 17:34:44 PST
It never seems to pass for me.  Maybe if I started with an empty cache.

Comment 4 Robert Blaut 2008-02-11 03:13:23 PST
Checked the Acid3 test again (it was changed a little - we pass only 79/100 now, red cat displays now).

On the first run the test 80 failed (78/100). After reload the test passed (79/100).
Comment 5 Eric Seidel (no email) 2008-02-12 01:54:14 PST
This and bug 16770 refer to the same Acid3 failure.  Which is the real cause, I'm not sure.
Comment 6 Robert Blaut 2008-02-17 12:19:15 PST
The issue relies on onload so it turns my attention to behavior reported in bug 15137 or maybe in bug 14693.
Comment 7 Darin Adler 2008-02-24 00:33:09 PST
I believe the reason this test fails on reload may be that on reload the frame gets a new src attribute, but reload simply reloads the old URL. Firefox 2 fails the same way (I didn't try a Firefox 3 beta), and it's possible this is a feature, not a bug.

When I wrote the regression test LayoutTests/fast/history/subframe-is-visited.html I worked around this by giving the frame a new name each time. It's possible Acid3 should be modified to do the same thing. Or maybe this truly is a bug.
Comment 8 Darin Adler 2008-02-24 00:34:44 PST
Hmm, after saying all that, I tested and with my latest fix, this seems to work even on reload.

I'm going to say FIXED for this bug.
Comment 9 Ian 'Hixie' Hickson 2008-02-24 01:19:08 PST
The script manually changes the src="" during the test, so it shouldn't matter if reload reloads the old URI.
Comment 10 Darin Adler 2008-02-24 01:45:07 PST
(In reply to comment #9)
> The script manually changes the src="" during the test, so it shouldn't matter
> if reload reloads the old URI.

Yes, I realize that.

But when I tried a simple test case, the page that manually changed the src of the iframe element did not load that new src on either Safari or Firefox. I know that sounds crazy. Obviously I didn't understand the issue thoroughly since I can't explain it right now. But there's something unusual going on with frame reloading and dynamic changes to the iframe src attribute, in both browsers.