Bug 172223 - [MediaStream] videoWidth and videoHeight should be set when 'loadedmetadata' event fires
Summary: [MediaStream] videoWidth and videoHeight should be set when 'loadedmetadata' ...
Status: ASSIGNED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Eric Carlson
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2017-05-17 09:10 PDT by Eric Carlson
Modified: 2017-05-18 17:55 PDT (History)
6 users (show)

See Also:


Attachments
Proposed patch. (10.79 KB, patch)
2017-05-17 10:46 PDT, Eric Carlson
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews107 for mac-elcapitan-wk2 (1.30 MB, application/zip)
2017-05-17 11:37 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews100 for mac-elcapitan (992.47 KB, application/zip)
2017-05-17 11:55 PDT, Build Bot
no flags Details
Patch for landing. (12.32 KB, patch)
2017-05-17 13:13 PDT, Eric Carlson
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews102 for mac-elcapitan (1.05 MB, application/zip)
2017-05-17 15:05 PDT, Build Bot
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Carlson 2017-05-17 09:10:40 PDT
videoWidth and videoHeight should be set when 'loadedmetadata' event fires
Comment 1 Eric Carlson 2017-05-17 09:11:54 PDT
<rdar://problem/31899755>
Comment 2 Eric Carlson 2017-05-17 10:46:34 PDT
Created attachment 310409 [details]
Proposed patch.
Comment 3 Build Bot 2017-05-17 11:36:59 PDT
Comment on attachment 310409 [details]
Proposed patch.

Attachment 310409 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.webkit.org/results/3763873

New failing tests:
fast/mediastream/MediaStream-video-element-video-tracks-disabled-then-enabled.html
Comment 4 Build Bot 2017-05-17 11:37:01 PDT
Created attachment 310417 [details]
Archive of layout-test-results from ews107 for mac-elcapitan-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: ews107  Port: mac-elcapitan-wk2  Platform: Mac OS X 10.11.6
Comment 5 Build Bot 2017-05-17 11:55:28 PDT
Comment on attachment 310409 [details]
Proposed patch.

Attachment 310409 [details] did not pass mac-ews (mac):
Output: http://webkit-queues.webkit.org/results/3763984

New failing tests:
http/tests/appcache/404-resource-with-slow-main-resource.php
Comment 6 Build Bot 2017-05-17 11:55:29 PDT
Created attachment 310420 [details]
Archive of layout-test-results from ews100 for mac-elcapitan

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: ews100  Port: mac-elcapitan  Platform: Mac OS X 10.11.6
Comment 7 Eric Carlson 2017-05-17 13:13:37 PDT
Created attachment 310432 [details]
Patch for landing.
Comment 8 WebKit Commit Bot 2017-05-17 14:31:56 PDT
Comment on attachment 310432 [details]
Patch for landing.

Clearing flags on attachment: 310432

Committed r217001: <http://trac.webkit.org/changeset/217001>
Comment 9 Build Bot 2017-05-17 15:05:19 PDT
Comment on attachment 310432 [details]
Patch for landing.

Attachment 310432 [details] did not pass mac-ews (mac):
Output: http://webkit-queues.webkit.org/results/3764877

New failing tests:
http/tests/appcache/404-resource-with-slow-main-resource.php
Comment 10 Build Bot 2017-05-17 15:05:21 PDT
Created attachment 310449 [details]
Archive of layout-test-results from ews102 for mac-elcapitan

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: ews102  Port: mac-elcapitan  Platform: Mac OS X 10.11.6