RESOLVED FIXED 172008
WebAssembly: implement name section's module name
https://bugs.webkit.org/show_bug.cgi?id=172008
Summary WebAssembly: implement name section's module name
JF Bastien
Reported 2017-05-11 19:20:16 PDT
Attachments
patch (5.02 KB, patch)
2017-07-03 08:32 PDT, JF Bastien
no flags
JF Bastien
Comment 1 2017-07-03 08:32:48 PDT
Build Bot
Comment 2 2017-07-03 08:33:46 PDT
Attachment 314485 [details] did not pass style-queue: ERROR: Source/JavaScriptCore/wasm/WasmFormat.h:248: static_cast is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] Total errors found: 1 in 3 files If any of these errors are false positives, please file a bug against check-webkit-style.
Keith Miller
Comment 3 2017-07-05 09:23:00 PDT
Comment on attachment 314485 [details] patch r=me.
WebKit Commit Bot
Comment 4 2017-07-05 09:52:02 PDT
Comment on attachment 314485 [details] patch Clearing flags on attachment: 314485 Committed r219134: <http://trac.webkit.org/changeset/219134>
WebKit Commit Bot
Comment 5 2017-07-05 09:52:04 PDT
All reviewed patches have been landed. Closing bug.
Saam Barati
Comment 6 2017-07-05 13:51:38 PDT
Comment on attachment 314485 [details] patch View in context: https://bugs.webkit.org/attachment.cgi?id=314485&action=review > Source/JavaScriptCore/ChangeLog:26 > + so I can't write a simple binary test; and using the name is a > + slightly riskier change because it requires changing StackVisitor > + + StackFrame (where they print "[wasm code]") which requires > + figuring out the frame's Module. The latter bit isn't trivial > + because we only know wasm frames from their tag bits, and > + CodeBlocks are always nullptr. I think we should just have Wasm::Callee's know their names. We can also have Wasm::Callee know its module. I don't think it's bad for these to grow a bit in size. This seems inevitable for doing wasm debugging.
Note You need to log in before you can comment on or make changes to this bug.